
   

 

Userôs Guide 
Version 11 

 

 

 
 

 



 TRS11 Page ii 

 

 

 

 

Copyright © 2011 JMM Software, Inc.  All rights reserved. 
Printed in the U.S.A. 

Any production or transfer of all or part of this document without written permission from JMM 
Software is strictly prohibited. 

The software described in this manual is subject to change.  Although we make every endeavor 
to ensure accuracy, JMM assumes no responsibility for any information that may be obsolete or 
erroneous, or for how this manual is used. 

 

Mail JMM Software, Inc. 

316 El Portal Way 

San Jose, CA  95119 

Telephone Phone: (408) 578-3552 

Fax: (703) 935-7782 

Email sales@jmmsoftware.com 

support@jmmsoftware.com 

training@jmmsoftware.com 

Website http://www.jmmsoftware.com 

mailto:sales@jmmsoftware.com
../AppData/Local/Microsoft/Windows/Temporary%20Internet%20Files/Content.IE5/QBSL09TV/support@jmmsoftware.com
http://www.jmmsoftware.com/


 TRS11 Page iii 

Table of Contents 
 

1. General Overview .......................................................................................................... 1 
Total Retail Solution ........................................................................................................ 1 
About This Manual........................................................................................................... 1 
Descriptions of TRS Databases ....................................................................................... 1 
Basic Program Navigation ............................................................................................... 2 

The Database Notebook ............................................................................................ 2 
The Database Toolbar ............................................................................................... 3 
Jumping to a Customerôs Transaction ........................................................................ 4 
Jumping Back to a Customerôs Record ...................................................................... 4 

Data Entry ....................................................................................................................... 4 
Types of Data Entry Fields ......................................................................................... 4 

Modifying Records ........................................................................................................... 6 
Deleting Records ............................................................................................................. 6 

Single Record ............................................................................................................ 6 
Old Records ............................................................................................................... 7 

Searching for Database Records ..................................................................................... 7 
Quick Search ............................................................................................................. 7 
Complex Search ........................................................................................................ 8 
SQL Search - Custom Query Reports ...................................................................... 10 
Special Searches ..................................................................................................... 10 
Switching Between a Found Set and the Entire Database ....................................... 10 

Using Found Sets .......................................................................................................... 11 
Listing a Found Set .................................................................................................. 11 

Reports .......................................................................................................................... 12 
Viewing and Printing Text Reports ........................................................................... 12 
Viewing and Printing HTML Reports ........................................................................ 12 

2. Initial Set Up ................................................................................................................. 13 
Overview ....................................................................................................................... 13 
Set Up Lists ................................................................................................................... 13 

Departments ............................................................................................................ 16 
Makes and Models ................................................................................................... 17 
Vendors ................................................................................................................... 19 

Screen Designer ............................................................................................................ 19 
Customers Screen Properties Specifics ................................................................... 21 
Point of Sale Screen Properties Specifics ................................................................ 21 
Individual Screen Designs ....................................................................................... 21 
Import/Export Screen Settings ................................................................................. 21 

Configuration Wizard ..................................................................................................... 21 
Using Multiple TRS Databases ...................................................................................... 22 
Setting Required Fields ................................................................................................. 22 
Preferences ................................................................................................................... 22 

Set Preferences Screen ........................................................................................... 23 
Daily Reminders ............................................................................................................ 25 
Edit Footer Messages .................................................................................................... 26 
POS Setup Options ....................................................................................................... 27 

Hardware Tab .......................................................................................................... 27 
Taxes Tab ............................................................................................................... 29 



 TRS11 Page iv 

Department Options Tab.......................................................................................... 30 
Printing Tab ............................................................................................................. 31 
Inventory Tab ........................................................................................................... 33 
Customer Rewards Tab ........................................................................................... 35 
Accumulations ......................................................................................................... 37 
Discounts ................................................................................................................. 38 
Misc. Options Tab .................................................................................................... 39 

Customizing the Function Keys ..................................................................................... 41 
3. Customers ................................................................................................................... 43 

Initial Setup for Customers ............................................................................................ 43 
Customers Tab .............................................................................................................. 44 

Field/Button Descriptions ......................................................................................... 44 
Adding Customers ......................................................................................................... 46 
Modifying/Deleting Customers ....................................................................................... 46 
Customer History Screen............................................................................................... 47 
EZ Customer Search ..................................................................................................... 48 
Customer Spending/Volume Accumulations .................................................................. 49 

Setting Goals for Accumulations .............................................................................. 50 
Set Up Eligible Products .......................................................................................... 50 
Set Up Eligible Accumulations ................................................................................. 50 
Viewing a Customerôs Accumulations ...................................................................... 51 
Adding Accumulation Messages to Receipts ........................................................... 51 
Customer Loyalty Cards/Keytags ............................................................................. 51 
Custom Taxes ......................................................................................................... 51 
Tax Exempt Customers ........................................................................................... 52 

Customer Reports ......................................................................................................... 52 
Special Searches for Customers ................................................................................... 52 

By Amount Spent ..................................................................................................... 53 
Who has bought this item? ...................................................................................... 53 
Has this customer bought this item? ........................................................................ 53 
Who has taken classes? .......................................................................................... 53 
Who has taken a particular class? ........................................................................... 54 
Who has rented something? .................................................................................... 54 
Who has a machine not recently serviced? .............................................................. 54 
Who has bought items in a particular department? .................................................. 54 
Who has bought items by description? .................................................................... 54 
By Birthday Month ................................................................................................... 54 
Whose email has changed? ..................................................................................... 54 

Customer Super Search ................................................................................................ 55 
Merging Customer Records ........................................................................................... 57 

Using Merge Two Customers Utility ......................................................................... 57 
Using Duplicate Customer Find/Merge .................................................................... 57 

Mailing Labels ............................................................................................................... 58 
Labels Supported by TRS ........................................................................................ 58 
Printing a Single Mailing Label ................................................................................. 58 
Printing or Exporting a Set of Mailing Labels............................................................ 58 
Avery Label Spacing ................................................................................................ 59 

Interface to DAZzle Shipping Software .......................................................................... 59 
Customer Wish Lists (Gift Registry) ............................................................................... 60 

Creating/Editing/Printing .......................................................................................... 60 
Selling Items on the Wish List .................................................................................. 60 



 TRS11 Page v 

Special Pricing ............................................................................................................... 61 
4. Serialized Sales ........................................................................................................... 63 

Initial Setup for Serialized Sales .................................................................................... 63 
Sales Tab ...................................................................................................................... 64 

Field/Button Descriptions ......................................................................................... 64 
Adding Sales ................................................................................................................. 65 
Modifying or Deleting Sales ........................................................................................... 66 
Returning a Machine ..................................................................................................... 66 
Sales Reports for Serialized Items ................................................................................. 66 

Sales Summary ....................................................................................................... 67 
Sales Report by Salesperson .................................................................................. 67 
Commission Report for a Salesperson ..................................................................... 67 

5. Repairs ......................................................................................................................... 69 
Initial Setup for Repairs ................................................................................................. 69 
Repairs Tab ................................................................................................................... 70 

Field/Button Descriptions ......................................................................................... 70 
Adding a New Repair ..................................................................................................... 72 

From the Customers Tab ......................................................................................... 72 
From the Sales or Repairs Tab ................................................................................ 73 

Modifying or Deleting Repairs ........................................................................................ 73 
Repair Email Notifications and Other Special Buttons ................................................... 73 
Entering Parts and Labor on the Repair Screen ............................................................ 73 

Enter Line Items Manually ....................................................................................... 73 
Scan Parts and/or Labor .......................................................................................... 74 
Labor Prices from Work Performed .......................................................................... 74 
Using the ñSearch for a Partò Button ........................................................................ 74 

Finishing the Repair ....................................................................................................... 75 
Repair Reports .............................................................................................................. 75 

Repair Report by Technician ................................................................................... 76 
To-Do List ................................................................................................................ 76 

Special Searches for Repairs ........................................................................................ 76 
Overdue (Past Promise Date) .................................................................................. 76 

6. Leads ............................................................................................................................ 77 
Initial Setup for Leads .................................................................................................... 77 
Leads Tab ..................................................................................................................... 77 

Field/Button Descriptions ......................................................................................... 78 
Adding a New Lead ....................................................................................................... 78 
Modifying or Deleting Leads .......................................................................................... 79 
Searching ...................................................................................................................... 79 
Special Searches for Leads ........................................................................................... 80 

Time to Follow Up .................................................................................................... 80 
7. Classes ......................................................................................................................... 81 

Initial Setup for Classes ................................................................................................. 81 
Classes Tab .................................................................................................................. 81 

Field/Button Descriptions ......................................................................................... 82 
Adding Classes ............................................................................................................. 82 
Modifying or Deleting Classes ....................................................................................... 82 
Undelete Entire Class .................................................................................................... 83 
Edit and Print Info Sheet Buttons ................................................................................... 83 
Class Reports ................................................................................................................ 84 

Enrollment List for Class Section ............................................................................. 84 



 TRS11 Page vi 

List of All Classes and Sections Currently Scheduled .............................................. 84 
Class Success Report ............................................................................................. 84 

Special Searches for Classes ........................................................................................ 84 
Time to Cancel (Low Enrollment) ............................................................................. 85 

8. Sections ....................................................................................................................... 87 
Initial Setup for Sections ................................................................................................ 87 
Sections Tab ................................................................................................................. 88 

Field/Button Descriptions ......................................................................................... 88 
Adding Sections ............................................................................................................ 90 

Copying a Section.................................................................................................... 90 
Modifying or Deleting Sections ...................................................................................... 90 
Undeleting a Class Section ............................................................................................ 91 
Enrolling Customers in Classes ..................................................................................... 91 

Copying Students from One Section to Another ....................................................... 92 
Modifying Enrollments ................................................................................................... 92 

Un-Enrolling Customers from Classes/Waiting Lists ................................................ 92 
Sorting the Enrollment/Waiting Lists ........................................................................ 93 

Adding Customers to a Class Waiting List ..................................................................... 93 
Sending Class Email Notifications ................................................................................. 94 

9. Accounts/Layaways .................................................................................................... 95 
Initial Setup of Accounts/Layaways ............................................................................... 95 
About Accounts and Layaways ...................................................................................... 95 

Layaway Considerations .......................................................................................... 95 
Accounts/Layaways Tab ................................................................................................ 96 

Field/Button Descriptions ......................................................................................... 96 
Layaways ...................................................................................................................... 98 

Adding New Layaways ............................................................................................ 98 
Receiving Additional Payments on Layaways ........................................................ 103 
Picking Up (Redeeming) Layaways ....................................................................... 103 

Store Charge Accounts ............................................................................................... 106 
Adding New Charge Accounts ............................................................................... 107 
Adding Charges to an Existing Account ................................................................. 111 
Receiving Payments on the Account ..................................................................... 112 
Refunding a POS Sale to a Store Charge Account ................................................ 112 

Store Credit Accounts .................................................................................................. 112 
Store Credit Accounts for Refunds ......................................................................... 113 
Store Credits Issued for Special Cases .................................................................. 113 
Manually Creating a Store Credit Account ............................................................. 114 
Adding Refunds to an Existing Credit Account ....................................................... 115 
Applying a Store Credit to a POS Sale ................................................................... 115 
Refunding a Store Credit as Cash ......................................................................... 116 

Canceling Account Transactions in POS ..................................................................... 116 
Modifying Account Transactions .................................................................................. 117 
Special Searches for Accounts .................................................................................... 117 

Charge Accounts with Money Owed ...................................................................... 118 
Overdue Charge Accounts ..................................................................................... 118 
Store Credit Accounts with Money in Them ........................................................... 118 
Layaway Accounts with Money in Them ................................................................ 118 

10. Point of Sale ............................................................................................................... 119 
Initial Setup for POS .................................................................................................... 119 

Answering Initial Prompts ...................................................................................... 119 



 TRS11 Page vii 

Buttons and Function Keys .......................................................................................... 121 
POS Functions Menu .................................................................................................. 121 
POS Screen ................................................................................................................ 122 

Field/Button Descriptions ....................................................................................... 122 
Starting a New Sale ..................................................................................................... 126 

New Anonymous Sale ........................................................................................... 127 
New Sale for a Customer ....................................................................................... 127 

Entering Items into a POS Sale ................................................................................... 128 
Barcode Scanner ................................................................................................... 128 
Enter Item ID ......................................................................................................... 128 
Quick Pick ............................................................................................................. 128 
Search for Item by Description ............................................................................... 128 
Enter an Unlisted Item ........................................................................................... 128 

Modifying the Quick Pick Button Contents ................................................................... 129 
Editing/Modifying an Item ............................................................................................ 129 

Editing an Item ....................................................................................................... 129 
Increasing the Quantity of an Item ......................................................................... 130 
Deleting an Item from a POS Sale ......................................................................... 130 

Discounts .................................................................................................................... 130 
Item Discount ......................................................................................................... 131 
Discount by Dollar Amount .................................................................................... 131 
Compound Discounts ............................................................................................ 132 
Discount all Undiscounted Items ............................................................................ 132 
Sale Discounts ....................................................................................................... 132 

Returns ........................................................................................................................ 133 
Entering Returned Items ........................................................................................ 133 
Returning a Serialized Item .................................................................................... 133 
Processing Refunds ............................................................................................... 133 

Canceling a Sale ......................................................................................................... 135 
Gift Certificates and Gift Cards .................................................................................... 136 

Gift Certificates ...................................................................................................... 136 
Gift Cards .............................................................................................................. 137 

Charging a Sale to a Store Charge Account ................................................................ 140 
Applying a Store Credit to a Sale ................................................................................. 140 
POS Layaway Sales .................................................................................................... 140 

POS Layaway Pickup ............................................................................................ 140 
Manage (View or Cancel) POS Layaways ............................................................. 140 

Redeeming a Non-POS Layaway ................................................................................ 141 
Payments on Layaways and Store Charge Accounts .................................................. 141 
Suspending a Sale ...................................................................................................... 141 

Suspend a Sale ..................................................................................................... 142 
Recall a Suspended Sale....................................................................................... 142 
Manage Suspended Sales ..................................................................................... 142 

Remote Sales (Shows and Conventions) .................................................................... 142 
Copying the Database ........................................................................................... 142 
Exporting Sales from TRS ..................................................................................... 143 
Importing the Exported Sales Files Back into TRS ................................................. 143 

Non-Sale Transactions ................................................................................................ 143 
Drawer Balances ................................................................................................... 144 

Reviewing POS Sales Records ................................................................................... 145 
Field/Button Descriptions ....................................................................................... 145 



 TRS11 Page viii 

Over-Rings ............................................................................................................ 146 
Creating a Transaction List .................................................................................... 147 

11. Inventory .................................................................................................................... 149 
Initial Setup for Inventory ............................................................................................. 149 

Field/Button Descriptions ....................................................................................... 150 
Adding New Products .................................................................................................. 155 

Copying Items ........................................................................................................ 155 
Modifying or Deleting Products .................................................................................... 156 
Automatically Generating Sequential Barcode Numbers ............................................. 156 
FIFO (First In, First Out) Costs .................................................................................... 156 
Entering Big Ticket (Serialized) Items .......................................................................... 157 

Setting up New Serialized Products ....................................................................... 157 
Modifying Serialized Items ..................................................................................... 158 

Manually Adjusting Inventory Quantities ...................................................................... 159 
Importing Inventory Count Adjustments ................................................................. 160 

Receiving Merchandise Without an Order ................................................................... 160 
Printing Barcode Labels .............................................................................................. 162 

Selecting Label Size .............................................................................................. 162 
Printing Labels ....................................................................................................... 162 
Printing from POS Products or Vendor Products ................................................... 162 

Checking Stock Levels ................................................................................................ 163 
Transferring Products Between Stores ........................................................................ 163 
Product Specials (Sale Pricing) ................................................................................... 164 
Using the ñPut on Saleò Button............................................................................... 165 

Creating Kits ................................................................................................................ 165 
Create a New Kit ................................................................................................... 167 
Edit Kit ................................................................................................................... 168 
Additional Options of the Kit Manager .................................................................... 169 

Exporting POS Inventory Products to a File ................................................................. 170 
12. Vendor Products ....................................................................................................... 171 

Initial Setup for Vendor Products ................................................................................. 171 
Vendor Products Tab ................................................................................................... 171 

Field/Button Descriptions ....................................................................................... 172 
Adding New Vendor Products ...................................................................................... 173 
Modifying or Deleting Vendor Products........................................................................ 173 
Adding a Vendor Product to the POS Products (Inventory) Database ......................... 174 
Importing Products ...................................................................................................... 174 

Importing from a Vendor File ................................................................................. 174 
Field Descriptions .................................................................................................. 175 
Importing from Another TRS Database .................................................................. 176 

13. Serialized Inventory ................................................................................................... 177 
Initial Setup of Serialized Inventory .............................................................................. 177 
Serialized Inventory Tab .............................................................................................. 178 

Field/Button Descriptions ....................................................................................... 178 
Adding a Serialized Inventory Item .............................................................................. 179 
Editing Serialized Inventory ......................................................................................... 181 
Deleting Serialized Inventory ....................................................................................... 181 
Selling a Serialized Item .............................................................................................. 181 
Integrating with POS Inventory .................................................................................... 181 

14. Orders ........................................................................................................................ 183 
Initial Setup for Orders ................................................................................................. 183 



 TRS11 Page ix 

Orders Screen ............................................................................................................. 183 
Field/Button Descriptions ....................................................................................... 184 

Creating New Orders ................................................................................................... 186 
Using Auto-Order ................................................................................................... 186 
Manually Creating a New Stock Order ................................................................... 187 
Importing an Order from the Portable Data Terminal (PDT Scanner) ..................... 187 

Adding Items to an Order ............................................................................................ 190 
Add a Blank Row ................................................................................................... 190 
Search by Description ............................................................................................ 190 

Modifying or Deleting Orders ....................................................................................... 191 
Deleting an Item .................................................................................................... 191 

Printing a Purchase Order ........................................................................................... 191 
Sending Orders Electronically ..................................................................................... 192 

Define the Method ................................................................................................. 192 
Set up the Vendor Details ...................................................................................... 192 
Send the Order ...................................................................................................... 193 

Special Orders ............................................................................................................. 193 
Creating a New Special Order ............................................................................... 194 
Combining Special Orders with Stock Orders ........................................................ 194 
Linking Multiple Orders .......................................................................................... 195 
Ringing Up a Special Order ................................................................................... 195 

Checking In Orders...................................................................................................... 196 
Change Costs and Pricing ..................................................................................... 197 
Print Barcodes ....................................................................................................... 197 
Add or Generate Barcodes .................................................................................... 198 
Serialized Inventory ............................................................................................... 198 
Print Check In Report ............................................................................................ 199 

Special Searches for Orders ........................................................................................ 199 
All Incomplete Orders ............................................................................................ 199 
Containing a Certain Item ...................................................................................... 199 
Special Orders Not Picked Up ............................................................................... 199 
Unlinked Special Orders ........................................................................................ 199 

15. Easy Service .............................................................................................................. 201 
Initial Setup for Easy Service ....................................................................................... 201 
Easy Service Tab ........................................................................................................ 202 

Field/Button Descriptions ....................................................................................... 202 
Adding a New Easy Service Ticket .............................................................................. 204 

From the Customers Tab ....................................................................................... 204 
Modifying or Deleting Easy Service Tickets ................................................................. 204 
Entering Services ........................................................................................................ 205 

Editing or Deleting Rows........................................................................................ 205 
Finishing the Service ................................................................................................... 205 
Easy Service Special Searches ................................................................................... 206 

Overdue (Past Promise Date) ................................................................................ 206 
16. Rentals ....................................................................................................................... 207 

Initial Setup for Rentals ............................................................................................... 207 
Rentals Tab ................................................................................................................. 208 

Field/Button Descriptions ....................................................................................... 208 
Adding a New Rental ................................................................................................... 209 
Modifying or Deleting Rental Tickets ........................................................................... 210 
Taking a Deposit ......................................................................................................... 210 



 TRS11 Page x 

Receiving a Returned Rental ....................................................................................... 210 
Late Fees .............................................................................................................. 211 

Rentals Special Searches............................................................................................ 211 
Past Due ................................................................................................................ 211 

17. Point Of Sale Reports ................................................................................................ 213 
Report Descriptions and Instructions ........................................................................... 213 

Cash Accountability Report .................................................................................... 213 
Tender By Day ....................................................................................................... 214 
Custom Tax ........................................................................................................... 215 
Profit By Department ............................................................................................. 215 
POS Sales By Salesperson ................................................................................... 215 
Sales By Hour ........................................................................................................ 216 
Re-Order Lists ....................................................................................................... 216 
Purchase Orders ................................................................................................... 216 
Inventory Summary ................................................................................................ 217 
Stock Turnover ...................................................................................................... 217 
Unlisted Items Sold ................................................................................................ 218 
Best Sellers ........................................................................................................... 218 
Biggest Spenders .................................................................................................. 218 
Inventory Adjustments ........................................................................................... 219 
Gift Cards Given as Rewards ................................................................................ 219 
Items Purchased by This Customer ....................................................................... 219 

18. Credit Card Processing with PCCharge Payment Server ....................................... 221 
Credit Card Setup ........................................................................................................ 221 

SIM and TCP/IP ..................................................................................................... 223 
XML ....................................................................................................................... 223 

Processing a Credit Card Payment or Credit ............................................................... 224 
Processing a Debit Card Payment or Credit ................................................................ 226 

19. Utilities ....................................................................................................................... 229 
Backing Up TRS Data ................................................................................................. 229 

Recommended Backup Storage ............................................................................ 230 
Action Logging ............................................................................................................. 231 
Manual SQL Update .................................................................................................... 231 

Special Password Required for Inventory Updates ................................................ 232 
Internet Menu .............................................................................................................. 232 
Importing E-Commerce Sales from Key To The Web .................................................. 233 

Key to the Web ï Initial Setup ................................................................................ 233 
Field Descriptions .................................................................................................. 234 
Importing Key to the Web Sales ............................................................................. 234 

Importing E-Commerce Sales from Quiltropolis ........................................................... 235 
Quiltropolis ï Initial Setup ...................................................................................... 235 
Field Descriptions .................................................................................................. 236 
Importing Quiltropolis Sales ................................................................................... 236 

20. Security ...................................................................................................................... 239 
Firebird Security .......................................................................................................... 239 

Changing Passwords ............................................................................................. 239 
User Security ............................................................................................................... 241 

Overview ............................................................................................................... 241 
Setting up Employee ID ......................................................................................... 241 
Field/Button Descriptions ....................................................................................... 242 
Editing Security Levels .......................................................................................... 243 



 TRS11 Page xi 

Setting Clerk Passwords ........................................................................................ 245 
Entering Security Codes ........................................................................................ 246 
Continuous Login ................................................................................................... 247 

A. Security Checklist ..................................................................................................... 249 
B. Costs .......................................................................................................................... 255 
C. Obsolete Programs ................................................................................................... 257 

POS Report: Sales Breakdown by Department (obsolete) ........................................... 257 
Credit Card Processing with PC Authorize (obsolete) .................................................. 257 
QuickBooksá Export (IIF File Method ï Obsolete) ...................................................... 258 

Data That Can Be Exported (obsolete) .................................................................. 258 
Setting QuickBooksá Export Options (obsolete) .................................................... 259 
Exporting the Data from TRS (obsolete) ................................................................ 260 
Importing the Data Into QuickBooksá (obsolete) ................................................... 260 

 



 TRS11 Page xii 

This page intentionally left blank. 



 

General Overview TRS11 Page 1 

Chapter 1  

General Overview  

Total Retail Solution  

The Total Retail Solution (TRS) program is a comprehensive point of sale system you can use to 

streamline your retail business.  The partial screen below is the main TRS program. 

 

From this program screen you can perform nearly every task needed to run the vital sales and 

inventory portion of your business.  You can also track classes, repairs, services and rentals. 

This manual describes in detail the features and functions of the TRS program. 

About This Manual  

This userôs guide is for TRS Version 11, and includes instructions for using the Point Of Sale 

(POS) features.  If you have purchased TRS 11 without the Point Of Sale module, please 

disregard the parts of the manual that refer to Point Of Sale or POS. 

Descriptions of TRS Databases  

TRS is divided into different databases that all work together.  Below is a brief description of 

them. 

Customers 

Stores information about your customers.  Each record in the database 
stores a customer's name, address, email address, phone numbers, date 
added, last activity date, notes, classification information, and some spare 
fields for your own use. 

Sales 

Stores information about the sale of a single large-ticket or serialized item, 
such as a sewing machine, vacuum cleaner, etc.  It tracks who purchased 
it, the price paid, what salesperson sold it, the commission made and so 
forth. 

Repairs 

Stores information about repairs performed.  Each record tracks what 
machine and accessories the customer brought in, the service request, the 
work performed and the technician who worked on it, the prices for parts 
and labor, etc. 

Leads 
Tracks valuable sales leads.  Track information about the potential 
customer, such as the product demonstrated, the price quoted, the demo 
length, the current status, notes about the customer or demo, and so forth. 

Classes 
Tracks the classes you offer.  Each record in this database stores the 
name and description of the class. 
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Section 

Tracks each time you offer a class.  For instance, if you have a class 
called "Beginning Sewing", and you offer it 5 different times, each of those 
times is a "section".  Each record in this database stores information such 
as the dates and times of the section, the name of the instructor, the price, 
and the maximum number of students. 

Enrollment 
Tracks who is enrolled in the sections of your classes.  Each enrollment 
record stores data such as who is enrolled, what class and section they 
are enrolled in, and whether they have paid for the class yet. 

Accounts/Layaways 

Tracks layaways and store charges/credits.  It stores the important 
information about the account and all of the payments/transactions 
associated with it.  With layaways, it also stores the original amount of the 
purchase and the balance due. 

Point of Sale 
Tracks inventory and sales of products and services for your store.  It 
stores transaction details for every sale. 

Serialized Inventory 

Tracks inventory by serial numbers.  These are typically the big-ticket 
items you would enter into the sales database.  If you have the Point Of 
Sale module, you will use the POS product inventory to store the inventory 
for smaller items, such as notions.   

POS Products 
Inventory 

Stores data about the products you sell, such as description, retail price, 
cost, quantity on hand, and sources for purchasing the items. 

Vendor Products 
Stores product information specific to a particular vendor, such as their 
part number and pricing. You may have numerous vendors from which you 
can order inventory items you carry in your store. 

Orders 
Tracks what you ordered, when the shipment was received, and so forth.  
Combined with Point Of Sale, it creates automatic orders (for your review), 
based on stock levels.   

Easy Service 
Stores information about services performed.  Each record tracks the 
service request, the work performed and notes about the work performed. 
The specific charges are also recorded. 

Rentals 
Tracks rental details, such as the customer, rented items, due dates and 
charges. 

 

Basic Program Navigation  

Most of the databases in TRS work in a very similar manner to each other.  Following is some 

general information about how to get around in TRS, how to enter new records into the database, 

modify existing records, delete records, and navigate through records. 

The Database Notebook  

The database notebook tabs make it easy to switch between one record type (customers, sales, 

repairs, leads, etc.) and another.  The database notebook tabs are shown below. 
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To access a screen, click on the appropriate notebook tab with the mouse.  Alternatively, you 

may switch between tabs with the keyboard by holding down the Alt key and pressing the 

corresponding number of the tab (for tabs 1-0).  

The Database Toolbar  

The database toolbar (pictured below) is used navigate through records, as well as add, edit, 

delete and refresh. 

 

The buttons on the database toolbar are described below, with the associated keyboard shortcuts. 

 Go to the first record (Shortcut key: Ctrl-F) 

" Go to the previous record (Shortcut key: Ctrl-P) 

# Go to the next record (Shortcut key: Ctrl-N) 

 Go to the last record (Shortcut key: Ctrl-L) 

+ Insert a new record (Shortcut key: Ctrl-I) 

 Delete the current record (Shortcut key: Ctrl-D) 

$ Edit the current record (Shortcut key: Ctrl-E) 

* Post (Save) modifications (Shortcut key: Ctrl-O) 

: Cancel modifications (Shortcut key: Ctrl-A) 

 Refresh data (Shortcut key: Ctrl-R) 

Hover over any one of the buttons on the toolbar without clicking, and the description of the key 

displays. 

Go to the First or Last Record 

You can display the first or last record in any of the databases by clicking on the  or  buttons 

on the database toolbar respectively. 

NOTE  If a found set of records is currently displayed (see page 11), the First and Last 

commands will take you to the first and last records in the found set, not the entire 

database. 

Go to the Next or Previous Record 

When any type of record is displayed, you can navigate through the records in the database by 

going to the next or previous record in the database. 

To go to the next record in a database click on the # or " buttons respectively on the toolbar.  

If either of these buttons are grayed out, you are already at the first or last record in the database. 

NOTE  If a found set of records is currently displayed (see page 11 for information about found 

sets), the Next and Previous commands will take you to the next and previous records 

in the found set, not the entire database 
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Jumping to a Customerôs Transaction 

When the history is displayed on the customer screen, the list boxes on the right show the 

customerôs sales, repairs, leads, enrollments, POS sales transactions, and so forth.  You can jump 

directly to any of these records by double-clicking on the entry in the list box (refer to the 

customer history screen on page 47). 

Jumping Back to a Customerôs Record  

Whenever a record (transaction, enrollment, service, etc.) is displayed, you can quickly jump to 

the corresponding customerôs record by clicking the ñGo to this customerò button. 

Data En try  

Types of Data Entry Fields  

There are several types of data entry fields in TRS.  The different types are discussed below. 

 

The figure above shows a basic text entry field.  To enter data into this type of field, either use 

the tab key to move the cursor to the field, or click on it with the mouse.  Enter the information. 

Following are valid entries for date fields: 

MM/DD/YY 

MM/DD/YYYY 

MMDDYY 

MMDDYYYY 

MMDD 

If you leave out the slashes, as in the last three formats, you MUST enter two digits for month 

and two digits for day.  For example, February 7, 2011 would be entered as 020711 or 02072011.  

If you are entering the slashes, you can leave out the leading zeros.  For example, enter the above 

date as 2/7/2011.  If you enter it as MMDD (leaving off the year), the current year is assumed. 

Many of the functions in TRS will prompt for a date range with the standard Windowôs graphic 

calendar (shown below) where you can click the desired dates. 
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Following is an example of a memo field. 

 

Memo fields hold longer amounts of text.  They are the same as a regular text entry field, except 

you can enter multiple lines using the Enter key to go to the next line. 

The following figure shows a drop-down list.   

 

This type of data entry field allows you to select from a certain set of values.  Choose the desired 

entry from the list that ñdrops downò. 

To display the list, click on the = button to the right of the text area.  Use the scrollbar to scroll 

through the items if the list is longer than the box.  To select an item from the list, click on it with 

the mouse.  Drop-down lists are defined in the Edit Lists menu.  To create or modify the list, 

please see Set Up Lists starting on page 13.   

Some of the drop-down list fields have a regular text entry field directly above it (linked to the 

same database field).  You can either select a value from the list or enter a value not in the list.  

Entering (typing) a value in the field is not recommended and in some cases (such as makes and 

models of machines) will cause undesired effects in TRS. 
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The figure above shows a checkbox.  This type of field is either checked or unchecked (on or 

off). To toggle the value of a checkbox, either click on it with the mouse or ñtabò to the field and 

then press the spacebar. 

Modifying Records  

To modify a record (customers, sales, classes, etc.), follow these steps: 

¶ Display the record you want to modify.  See searching (page 7) or navigating (page 2). 

¶ Click on the < (edit) button on the database toolbar. 

¶ Edit the information on the screen.  Type over or append the text already in the field, 

choose new values from the drop-down lists, or check and uncheck the checkboxes. 

¶ When you are finished editing the record, save your modifications by clicking on the * 

(save) button on the database toolbar.  To abandon the changes you have made, click on 

the X (cancel) button on the database toolbar. 

The updated record will display on the screen. 

Deleting Records  

There are two different ways to delete records from the database.  The first is to delete a single 

record.  The second is to delete all records of a particular type that are older than a certain date. 

Single Record  

To delete a single record from the database, follow these steps: 

¶ Display the record you want to delete.  See searching (page 7) or navigating (page 2). 

¶ Click on the ï (delete) button on the database toolbar. 

¶ A confirmation message box displays, verifying whether you really want to delete this 

record.  Click "Yes" or press Enter.  

The record will be deleted from the database. 

WARNING S  If you delete a customer from the database, all sale, repair, lead, and enrollment 

records for that customer will also be deleted.  This data will be lost forever.  Any 

reports (other than Point Of Sale) will no longer include these deleted records.  

Do not delete a customer unless you are absolutely sure that any sale, repair, lead, 

and enrollment records for that customer are no longer needed.  When you delete 

a customer, their Point Of Sale records will remain in the database, but they will 

not be linked to the customer.  

 

If you delete a class record, all of its sections and enrollments will be deleted.  

 

If you delete a section record, all enrollment records for that section will be 

deleted as well. 
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Old Records  

Occasionally, you may want to delete old records of sales, repairs, leads, sections, enrollments, 

POS sales, specials or special orders that have been picked up.   

From the Maintenance menu, select the type of record you want to delete. 

 

Enter the cutoff date for deleting records.  For example, if you want to delete all sales occurring 

before January of 1999, enter 1/1/99 at the date prompt.  You may be prompted to type a certain 

phrase before TRS will perform the task.  This is to prevent accidental removal of important 

records. 

WARNING   Consider keeping old records for as long as possible, so you can run reports 

against the data.  Once you have deleted these old records they will no longer 

show up in any reports.  Before using this operation, please make sure you no 

longer need to keep the data you are deleting. 

Searching for Database Records  

TRS has three basic methods of searching database records:  

¶ Quick Search 

¶ Complex Search 

¶ SQL Search 

There is also an E-Z Customer Search for quickly finding customers (see page 48) and numerous 

built-in Special Searches (described in the appropriate sections in this manual, such as Sales, 

Leads, or Repairs). 

The results of a search are considered a ñfound setò.  Refer to Using Found Sets on page 11 for 

more information. 

Quick Search  

Press the ñQuick Searchò button on the screen from which you wish to search.  A quick search 

form for that database, similar to the one shown next will display. 
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Fill in the fields with the appropriate data and click "Find".  TRS will bring up all records that 

match.  For numeric fields, the number must be entered exactly for it to find the record.  For text 

fields, you can enter partial values.  For example, if you type ñluò in the ñLast Nameò field, it 

will find customers with last names Lu, McClure, Ludwig, Desilu, and others.  Fields having 

drop-down options will also be drop-downs on the Quick Search screen.   

Checkboxes can be set to gray, dark, or blank.  Click on the checkboxes to toggle the values.  A 

gray checkmark will not search on that field at all; a dark checkmark will find all records that 

have the checkbox checked; and, no checkmark in the box (blank) will find records that have the 

checkbox unchecked.  Repeatedly clicking on the checkbox toggles between the three values.   

The Customer Quick Search has a checkbox labeled ñSort By Zip Codeò.  If you check it, the 

results will be in zip code order for printing mailing labels. 

The results from the search become what is called a ñfound setò and can be printed as a report, or 

in the case of customer, sale, repair or leads searches, can be used for mailing, email, or a phone 

lists.  See Using Found Sets on page 11 for more details. 

Complex Search  

Complex searches offer more flexibility for searching specific groups of records using ñand/orò 

logic.  Add search conditions one at a time, and click "OKò.  TRS will bring up all records that 

match your conditions. 

Click the ñComplex Searchò button on the screen from which you wish to search. Click the 

ñSearch Assistantò button and a complex search form for that database, similar to the one 

displayed below will display. 



General Overview TRS11 Page 9 

 

To add a search condition, select the field to search by in the Field list box.  Next, click on the 

desired condition in the Condition list box.  Then, enter the value to search for in the Value field.  

For example, to find all customers who have a zip code starting with ñ954ò, select ñZipò from 

the Field list box, ñStarts Withò in the Condition list box, and ñ954ò (without the quotes) in the 

Value field.  

Click the ñAddò button.  The search condition will appear in the list box at the bottom (in SQL 

form).   

You can use the ñIs Betweenò Condition to search for a range of values, such as dates.  When 

you select ñIs Betweenò in the Condition list, a second Value entry field displays on the screen 

so you can enter the beginning and ending range of values for your search.  If you have selected 

a date field to search by, the standard Windowôs graphic calendar will display for convenience.  

Continue adding search conditions until you have completely defined the search.  You can 

remove any of the search conditions by selecting it in the list box and clicking the ñRemoveò 

button. 

You can also specify which fields you would like to sort by.  Select a field from the ñFieldò list 

box and then click the ñSort Byò button.   That field will be added to the list of fields to sort on.  

You can sort by multiple fields.  For instance, to sort by last name, then first name, add both of 

the fields in that order. 

When you have finished entering the search conditions, select a ñjoin modeò from the buttons in 

the lower left corner of the screen.  ñAndò means that you want to find records that meet every 

single one of your search conditions.  ñOrò means that you want to find all records that meet at 

least one of your search conditions.   

When you are finished entering the sort criteria, click ñOKò. 

The SQL version of your search displays on the screen.  Click ñOKò.  These results from the 

search become what is called a ñfound setò and can be printed as a report, or in the case of 
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customers, sales, repairs, leads, and class sections can be used for mailing, email, or phone lists.  

See Using Found Sets on page 11 for more details. 

SQL Search -  Custom Query Reports  

If you can write SQL queries, you can get reports for just about any data in TRS.  You can also 

find numerous custom query commands on the JMM website under Support/Customer 

Resources/SQL Queries that can be copied into this screen.   

Select File>Custom Query Report from the TRS menu.  The Manual SQL Form displays 

(shown below). 

 

Enter or copy your SQL query in this form.  You can save it for later use with the ñSaveò button.  

Likewise, you can load a previously saved query with the ñLoadò button.  When you are done, 

click the ñExecute!ò button.  A list of fields selected in the query will display (refer to page 11). 

Select the fields to list on this report and click ñOKò.  The list will display. 

Special Searches  

For an explanation of each Special Search, refer to the individual chapters (Sales, Leads, Repairs, 

etc.) in this manual. 

Switching Between a Found Set and the Entire Database  

After performing a search (quick, special, complex, SQL), the results of that search are the only 

records available to navigate on that tab.  For example, if the search resulted in 10 customers, 

those are the only customer records that will show up if you scroll backward or forward.  In 

order to go back to browsing the whole database, change the View Options (shown below) to All 

Records/Add/Edit/Delete. 
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Using Found Sets  

The result of any search is considered a ñfound setò and can be utilized in several ways.  Once 

you have a found set displayed on the screen, select any of the following functions: 

¶ File>Export Mailing Labels for Found Set 

¶ File>Email List for Found Set 

¶ File>Send Bulk Email for Found Set 

¶ Reports>Mail Labels for Found Set 

¶ Reports>Phone List for Found Set 

¶ Reports>List Found Set 

You can also use the navigation toolbar to scroll backward and forward through the list. 

Listing a Found Set  

To create a list to either review on the screen or print a custom report, select Reports>List 

Found Set from the TRS menu.  The field selector screen displays, listing the fields available 

from the database being accessed (an example is shown next).   

 

Select the data to appear on the custom report (list) by marking the checkbox beside it and click 

ñOKò.  The list of the found records displays on the screen. You can then print it if desired. 
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Reports  

TRS reports are either presented in HTML or text format. There are a few exceptions where you 

can choose from either format. 

Viewing and Printing Text Reports  

Once you have selected a text-based report and entered the required information, the print out 

window displays the report (similar to the one displayed next). 

 

You can make modifications on the screen before printing it.   

You can print to either a laser/inkjet printer (8 ½ x 11 paper) or to the receipt printer (receipt 

paper).  Press ñView in WordPadò to bring the report up in Microsoft WordPad where you can 

edit, save and/or print it.  In some cases, the report will be too long to fit on the screen ï print or 

view it in WordPad to see the whole report. 

Viewing and Printing HTML Reports  

Once you have selected an HTML-based report and entered the required information, the report 

displays in either the TRS built-in HTML browser/editor or your computerôs default web 

browser, as specified in Edit>Preferences (see Preferences page 22).  You can make 

modifications on the screen (such as changing the title) before printing or saving the report. 

Click the ñSaveò button, to save your report to a file.  If you want to format or perform more 

calculations, you can open HTML files in Microsoft Excel. 

NOTE When a very large report is generated, it may take some time to load and display it.     
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Chapter 2  

Initial Set Up  

Overview  

There are numerous lists, options and preferences that must be set up as you implement TRS.  

Those functions are discussed in this chapter, as well as at the beginning of each chapter 

detailing the various screens in TRS (such as Customers, Sales, Repairs and so on). 

You can also refer to the Getting Started Guide for more information and useful tips for setting 

up your system.  

Set Up Lists  

One of the first tasks when implementing TRS is to set up the drop-down lists.  The values 

entered in the Edit Lists screens determine what options ñdrop downò in certain fields when 

entering and modifying records.  For consistency in storing and reporting data, selecting from 

drop-down lists is important.  
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The Edit Lists menu is shown below. 

 

Select the list to modify and the values currently in the list display.  When you are setting this list 

up for the first time, there may be no entries displayed. 

To add a new entry to the list, click ñAdd Blank Rowò.  A new row will appear; type in the new 

value to add to the list and press Enter.  To modify a particular entry, select it with the mouse so 

it is highlighted, type in the new value, and press Enter.  To delete an entry from the list, 

highlight it and click ñDelete Selected Rowò.  Select ñYesò when it prompts whether to delete it. 

To change the order in which the entries display in your drop-downs, click on a column heading 

to alphabetize or sort it.  Optionally, you can specify the order in the ñLISTORDERò field. To 

set the list order this way, enter numbers into this field.  The items in your drop-downs will 

appear in numerical order, according the LISTORDER field. 

You can also print the list by clicking ñReport (Print)ò. 

NOTE Some lists, such as Models and Sources will have additional fields that are used by 

other parts of the software.  You may have to scroll to the right to see and enter all of 

the fields. 
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The following table summarizes which parts of TRS use these drop-down lists. As you 

implement each part, you can use this table to determine which lists must be set up first. 

Tab Lists Used for Drop-Down Options 

Customers 

Customer Classifications 
Cities 
Custom Taxes 
Zip Codes 

Sales 

Makes 
Models 
Stores 
Sale Types 
Methods of Payment 

Repairs 

Technicians 
Repair Accessories 
Repair Service Requests 
Repair Work Performed 
Stores  
Methods of Payment 

Leads 

Make 
Model 
Demo Lengths 
Lead Statuses 

Classes No drop-downs 

Sections 
Instructors 
Methods of Payment 

Accounts/Layaways No drop-downs 

POS 
POS Categories (optional) 
Tender Types (optional) 

Serialized Inventory 
Makes 
Models 

POS Inventory 
Vendors 
Department Names 

POS Vendor Products Vendors 

Orders 
Vendors 
Stores 

Easy Service 

Service Type 
Service Options/Notes 
Service Items to Return 
Service Tech Notes  
Store 
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Tab Lists Used for Drop-Down Options 

Rentals 

Make 
Model 
Store 
Rental Accessories 
Rental Notes 
Rental Periods 
Rental Rates 

 

Because of the impact on your records, several of these lists require special attention and 

planning.  Following is a discussion of those lists. 

Departments  

It is important to decide on and set up your department structure before you enter your inventory 

and begin entering sales transactions in POS.  Each item in your storeôs inventory will be 

assigned to a department. You will also need departments for non-inventory items such as 

classes, postage or shipping and handling. Once you have your department names/numbers 

planned out, use Edit Lists>Departments to set them up. 

 
Departments are used to capture and categorize sales and cost totals for the Profit by Department 

report, and optionally, to export those totals to Quick Books.  In addition, they allow you to 

easily search inventory items by department and run reports, set up sale specials, or perform 

other tasks on a range of products, such as changing prices. 

The format for department numbers is like an outline where each major category can have sub-

categories to break down the data into more detail.  There can be up to 99 sub-categories in each 

major category.  For example, departments 101-199 are sub-categories of department 100, and 

departments 2201-2299 are sub-categories of department 2200.  

When you print a Profit by Department report, the sales details will be subtotaled by major 

category. You should set up a department (category) for each type of inventory you carry (such 

as notions, fabric, patterns, books, and threads).  Each of these departments could be major or 

you could define some of them as major ones with the others as sub-categories (see the examples 

of partial department lists that follow). 
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Sample Department List 1 Sample Department List 2 

100 Notions 1500 Notions 
 101 Scissors  1505 General Notions 
 102 Needles  1510 Rulers 
 103 Books  1515 Patterns 
200 Thread 1600 Thread 
 201 Sewing Thread  1605 Mettler Thread 
 202 Embroidery Thread  1610 YLI Thread 
 203 Quilting Thread  1615 Superior Thread 
300 Fabric 1700 Fabric 
 301 Moda  1725 $10 per yard fabric 
 302 Kona  1750 $11 per yard fabric 
 303 Maywood  1775 $9 per yard fabric 
 390 Kits 2000 Kits 
400 Classes 3000 Classes 
500 Shipping & Handling 4000 Miscellaneous 
1000 Promotions & Coupons 4010 Shipping & Handling 
  4020 Promotions & Coupons 

Even though departments can be changed and added later if you need to refine your list, it is 

advisable to set up the list as completely as possible at the beginning.  

Makes and Models  

In order to integrate the Serialized Inventory and Sales programs properly, you must set up the 

lists for each Make of machine (or large ticket item to be serialized) and each Model you carry in 

inventory.  Use Edit Lists>Makes and Edit Lists>Models to set up these lists.   

Once you have set up the Makes, enter the Models you carry so each machine can be set up as a 

serialized item. Include the Department, and if you are using POS, enter the Inventory Item ID 

(the barcode assigned to the inventory item in Inventory>Edit POS Products) for each 

Make/Model. TRS will cross-reference the inventory item (if the barcode is entered here) with 

the serial-numbered item and decrease both inventories when a sale is made.  Refer to pages 157 

and 181 for additional information. 

The following diagram shows these screens and how they work together. 
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Once the inventory is entered, you can select serial numbers from a list you display on the Sales 

screen.  When you are entering a sale, select the correct Make and Model from the drop-down 

lists first.  Then, instead of typing in a serial number for that item, click the ñSelect From Listò 

button to select a serial number from your inventory.  When you save the sale, the serial number 

will be removed from your serialized inventory and stored with this record.  
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Vendors  

Once you have set up a vendor list you can specify a preferred vendor for each item in your 

inventory, maintain product lists in your Vendor Products database, and generate suggested 

purchase orders automatically.  You can require vendor information to be entered for new 

inventory items by setting the option on the POS>Options>Inventory Tab. You may also set up 

details in the Vendor List Editor to send orders electronically to vendors who accept them (refer 

to page 192 for more information).   

Modifying Vendor Names 

When you edit a vendor name in Edit Lists, you will be prompted whether to automatically 

update it throughout the database. It is strongly recommended that you answer ñYesò to this 

prompt to ensure consistency in ordering and reporting. 

Screen Designer  

TRS allows you to change the default layout of each of the program tabs, as well as the property 

of each field or button on each of those tabs (such as adding a ñmouse-overò hint or changing the 

font color).  Access the Screen Designer from Edit> Screen Designer>Begin on the TRS menu. 

Using drag and drop, any button or text field can be moved on each screen.  One possible use for 

this feature is to remove buttons or fields your store is not using (such as ñPut on Layawayò and 

ñLayaway Pickupò on the Point of Sale tab). You can also use it to take advantage of touch 

screen technology.  You can arrange buttons and fields with additional space between them, as 

well as change the button and font size, to make it easier to select them by touching the screen. 

If youôd like to experiment with rearranging the screen or changing the properties without saving 

the changes, you can abort your current manipulations at any time by going back to Edit> 

Screen Designer and choosing Abort. (If you save your changes now and later want to reset 

everything to their original locations, select Edit>Screen Designer>Permanently Reset To 

Default.) 

When you have finished rearranging the screen elements, select Edit>Screen Designer>Finish.  

The program selection screen (shown next) will display. You can also access this program 

properties screen directly by selecting Edit>Screen Designer>Edit Properties. 

Even if you do not wish to edit the field or button properties, you can name your design to make 

it unique instead of modifying the default design. To do this, click on the ñNew Designò button 

and enter a name for this screen design and click ñOKò.  On the Screen Designer screen, click 

ñOKò to finish this session.  The drag and drop changes you made will be saved, as well as the 

new name if you entered one.   
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To edit the field and/or button properties, click the ñ+ò beside the program tab you wish to edit. 

The properties options for that screen display. 

 

The screen above displays the properties you can edit for the cash button on the ñPoint of Sale 

Bottomò (the cash tender button on the lower portion of the POS screen).  The properties list and 
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the screen for field labels, data entry fields, and other items (such as radio groups or checkboxes) 

will be specific to the changeable options for that selection. 

Customers Screen Properties Specifics  

You can make changes on the Customers screen with the ñShow Historyò button visible and with 

it hidden.  It depends on how the screen is displayed when you begin.  The Screen Designer will 

display a message (in red) in the lower right informing you which screen is being edited. 

Point of Sale Screen Properties Specifics  

If you decide to remove seldom-used buttons from the POS screen (by un-checking the 

ñVisible?ò checkbox), the functions are still available on the POS>Functions menu. For 

example, if you have made the ñCompound Discountò button invisible and find, in the middle of 

a sale, you need to use it, you can select it from the POS>Functions menu. 

When changing the arrangement (by dragging and dropping) on the screen, a button must be 

óactiveô for it to be movable. In other words, an active sale must be started before you can move 

most of the buttons (click the ñNew Anon. Saleò button to create an active sale). Once complete, 

cancel the active sale.     

Individual Screen Designs  

Each of the computers in your store may have a different screen design.  This is helpful if you 

have screens with different resolutions and sizes. For instance, the register computer may have a 

large, touch screen monitor; whereas, the back office may have a smaller, plain screen, never 

used as a register. Different designs could be more efficient and easier to see and use.   

Import/Export Screen Settings  

The export buttons on the Screen Designer Properties screen can be used to save the settings for 

a particular screen or all screens on a particular computer to a file. That file can then be imported 

to another computer by selecting Edit>Screen Designer>Import From File option. 

Configuration Wizard  

Use the Configuration Wizard to define the screens that will be visible when you are running 

TRS. For example, if your store doesnôt perform Repairs, uncheck the box that refers to Repairs 

& Maintenance. You can change these settings at any time in Edit>Configuration Wizard . 

When a tab (function) is turned off, there is a ripple effect depending on the interfacing features 

of that tab.  For instance, if you do not provide store charge, credit or layaway accounts and set 

the Configuration Wizard to leave that tab off your database notebook, the ñAcctsò section will 

not display in Customer History, the ñDepositò buttons do not appear on the Sales or Repairs 

tabs and none of the buttons concerning accounts and layaways appear on the Point of Sale tab. 

The Configuration Wizard also steps you through setting up the initial global type settings, such 

as additional store contact information and sales taxes.   

Use the ñBackò and ñNextò buttons to navigate through the screens, entering the desired details. 
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Using Multiple TRS Databases  

This is an optional, advanced feature.  You can define several database aliases in the Database 

Administrator.  This means you can have more than one set of data to use with TRS.  Common 

uses of this feature are setting up a practice database for training purposes or connecting to 

different databases for different stores.  Refer to the Knowledge Base on the JMM website for an 

article with instructions to set up a practice database. 

Setting Required  Fields  

For many of the screens in TRS, you can define the fields for which you require input.  For 

example, you can set it so fields such as Last Name, Home Phone and Zip Code are required for 

every new customer.  

To set up those required fields, select Edit>Required Fields.  Select the appropriate screen from 

the list displayed and the Required Fields Editor displays. These screens are shown in the 

following diagram. 

 

To set up a required field, select it from the Not Required list on the left and click the ñ->ò button 

to move that field to the Required list.  Conversely, to remove a field from the Required list, 

select the desired field and click the ñ<-ñ button to move it to the Not Required list.  

Preferences  

There are some options that you can set for the TRS program that are not specific to Point Of 

Sale.  To set these options, select Edit>Preferences from the TRS menu. 

NOTE If you have more than one computer running TRS in your store, the fields next to the 

yellow bullets typically must be set on each individual computer. Windows users may, 
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optionally, use the Windows login to determine these settings (explained in the 

following table).  

Set Preferences Screen  

 

The following describes the fields on this screen. 

Field Definitions 

Additional Contact 
Info 

Enter any additional contact information about your store (phone number, web site 
URL, etc.), to print at the top of printouts/receipts.  Do not put your storeôs address 
here ï the software already knows your storeôs address and will automatically 
include it on the printouts/receipts. 

Default State Enter a state abbreviation that will default whenever you enter a new customer. 

Currency Symbol If you do not use $ as your currency symbol, enter the symbol your country uses. 

Use Windows 
Default Web 
Browser for HTML 
Reports? 

Define how your computer will open the TRS HTML based reports. If you have 
trouble viewing HTML reports from within TRS, you may need to click this 
checkbox. 
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Field Definitions 

Use JMM Software 
Email Suite for 
sending order 
electronically? 

Check this box to send orders using the JMM Email Suite (which supports email 
server authentication).  If you do not check this box, orders will be sent using the 
function built in TRS (set up in Internet>Internet Setup). 

Default Tax Rates 

Enter your local sales tax rate in the ñParts/Merchandiseò field.  Use the ñLaborò 
field if your state requires tax on labor for repairs. (These tax rates are also defined 
in POS>Options>Taxes. When the tax rates are changed in either place they will 
be changed in both places and display on each screen.) 

Mono Display? 
If you are using a monochrome display, check this box and the color scheme will 
change slightly to be more readable on a non-color display. 

Refresh Data on 
Page Change 

When this box is checked, the system refreshes the data each time you switch to a 
new tab in TRS.  This will give you the latest data from the database, for example, 
if someone had just updated that data from another computer. (This may slow your 
system down.) 

Search last name 
before phone 
number on E-Z 
Customer Search 

This box defines the search order when using E-Z Customer Search.  

Check this box to search by last name before the phone number.  Uncheck or 
leave the box blank to search by phone number then last name. 

Automatically Clear 
Inactive Status 

Check this box to automatically clear the Inactive Status on a customer record if 
there is any new activity for them. 

Show reminders on 
startup 

Check this box to display the daily reminders window each time TRS is started.  
See below for more information about the daily reminders window. 

Multi Store? Check this box to add the multi-store functions menu to the TRS menu. 

Print Store Info on 
Reports? 

Check this box to print the store number, name and address on TRS reports. 

Make per-computer 
settings apply to all 
Windows users 

If this is checked, all of the settings in Edit>Preferences and 
POS>Options that are "per computer" (indicated by a yellow bullet), will apply 
to all Windows users on that computer.  

If this box is not checked, when users log onto the computer using different 
Windows logins, they will have their own set of ñyellow bulletò settings.  In this way, 
different Windows users on the same computer can have their own Preference 
and POS Options settings. 

HTML Editor 
Delayed Load  

Change this option if your HTML reports are coming up blank (or as instructed by 
JMMôs Technical Support). 

Photo Location 

To store photos of your inventory products that TRS can access, enter the path to 
the folder where the pictures reside. 

The picture file name must match the Barcode/Item ID with ñ.jpgò as the extension.  
For example, if the itemôs barcode number is 12345, the photo file should be 
named 12345.jpg.  

When you are in Edit POS Products, if the product displayed has a photo file in the 
folder defined here, a ñShow Photoò button will display near the bottom right of the 
screen (above the ñSourcesò section)ò. 

Fast Zip Lookup 
City Name 

If you have zip codes set up in Edit Lists>Zip Codes and use the ñFast Zip Code 
Lookupò on the Customers screen, this option allows you to define how TRS 
capitalizes the city name in the customer records. 
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Field Definitions 

Class Sections 
Default View 

Check one of these buttons to define the default display selection on the Classes 
tab. 

Include Old Sections ï Check this box to display all the sections for the class 
including those that have passed. 

Show Only Current ï Check this box to display only currently available sections for 
the class. 

Reset every time user switches to Classes tab ï Check this box so the screen will 
reset to the default when you leave and come back to the Classes screen, if you 
clicked to display other option.  If it is not checked, the last clicked option will 
display until you change it or restart TRS. 

Screen Design 
From the drop-down list, select the screen design for the current computer.  You 
may select a different screen design on each computer running TRS. 

Daily Reminders   

When you first start TRS, the Reminders screen appears (unless it has been disabled in the 

Edit>Preferences tab).  This screen displays a list of things that should be done or need 

attention (as seen on the following screen).  To see the detail of any of the reminders, click on 

the ñViewò button next to the item. The records are then available (as search results) in the 

appropriate tab (Repairs, Leads, etc.). 

 

You can bring up this screen at any time by clicking the ñRemindersò button on the TRS screen, 

as shown below. 
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Edit Footer Messages  

To customize the messages at the bottom of print-outs such as POS receipts, sales invoices, 

repair claim checks, etc., select the footer you want to set up from the File menu. 

Enter the desired verbiage in the text editor that displays.  You can enter as many lines of text as 

you need.  You can also restrict the text entry to 40 columns (check appropriate box at the 

bottom of the screen) so it will fit on a receipt instead of a full sized sheet of paper.  For instance, 

you could check this box for a repair claim check footer that typically prints on receipt paper and 

leave this box blank for serialized sales invoice footers that print on 8 ½ x 11 paper. 

The receipt/form each footer prints on is listed in the following table. 

Footer Prints On 

Sale Invoices from the Sales tab 

Repair Claim checks and invoices from the Repairs tab 

Quote Quotes 

Class Supply lists and class confirmations from the Classes/Sections tabs 

Special Order Special Order confirmations from the Orders tab 

Layaway/Account Account printouts from the Accounts/Layaways tab 

POS Receipts and invoices from the Point of Sale tab 

Easy Service Claim checks and invoices from the Easy Service tab 

Rentals Return slips and invoices from the Rentals tab 
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POS Setup Options  

This section describes the options that can be set for the Point Of Sale system.  To access the 

screen select POS>Options from the TRS menu. The screen is divided into several different 

tabs. Each tab is described in the rest of the chapter. . 

NOTE If you have more than one computer running TRS in your store, the fields with yellow 

bullets next to them must be set on each individual computer. The fields with green 

bullets affect all computers and only need to be set up on one. 

Hardware Tab  

 

The following describes the fields on this screen. 

Field Definitions 

Receipt Printer 
Attached 

Click this option on if you have a receipt printer attached to your system. 

Receipt Printer   
To define the printer to use for receipts, click the ñSelectò button.  Select the 
printer and click ñOKò. 
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Field Definitions 

Receipt Printer 
Type 

Use this drop-down box to select the model of your receipt printer.  

Note: If you are using an Epson TM-88III or TM-T88IV, select the Epson TM-
88II. 

Cash Drawer 
Attached   

Turn this option on if you have an electronic cash drawer attached to your receipt 
printer. 

Override Open 
Code   

In most cases, leave this field blank.  It can be used to send a special code to a 
non-supported cash drawer. 

Label Printer   
To define the label printer, click the ñSelectò button.  Select the printer and click 
ñOKò. 

Label Printer Type   

Indicate the label printer type. 
Eltron/Zebra refers to the Eltron/Zebra 2622/2722/2824 label printers. 
Cognitive refers to Cognitive Solutions Blaster Advantage label printers. Only the 
Blaster Advantage is known to work with TRS ï other similar Cognitive models 
do not work with TRS. 

Send Special Code 
Now   

Use this button to send special one-time commands to a printer (for setup and/or 
troubleshooting). 

Pole Display 
Attached 

If you have a customer pole display attached to your system, turn this option on. 

Pole Display Port 
Define the pole display as a Windows printer and enter the name here.  Refer to 
the TRS Installation Guide for more information. 

Pole Display New 
Sale Message 

To display a welcome message on the pole display whenever a new POS sale is 
started, enter it here. 

Pole Display End 
Of Sale Message 

To display a particular message when a POS sale is completed, enter it here.  
Be aware, however, this message is displayed INSTEAD of the change due 
amount ï the change amount will NOT come up on the pole display. 
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Taxes Tab  

 

The following describes the fields on this screen. 

Field Definitions 

Tax1, Tax2, Tax3 
Names/Rates 

Use these fields to define your tax rate(s).  Most businesses will only need to 
use Tax 1.  For each tax needed, fill in the name and tax rate. For more 
complex situations, optional custom tax rates can be set in Edit Lists>Custom 
Taxes.  

Which taxes apply 
toé 

Use these checkboxes to specify which of the above taxes apply to class fees, 
repair parts, repair labor, serialized items and rentals in your jurisdiction. 

Which taxes are 
selected by default 
on a new item? 

Define which of the tax rates will automatically be checked ñonò when entering a 
new item into the POS Products database. 

Always Round 
Sales Tax Up 

Some states require sales tax always be rounded up to the next full penny.  
Check this box if this is required in your state.  When the box is unchecked, 
normal mathematical rounding occurs. 

Use Tiered Tax on 
Serialized Items 

Some states require a tiered sales tax on big-ticket sales.  If your state requires 
this check here.  Fill in the appropriate price breaks in the ñCharge Taxò fields. 
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Field Definitions 

When customer is 
exempt from Tax 1, 
make them exempt 
from Tax 2 and Tax 
3 also. 

This checkbox is ñonò by default.  To set individual tax rates 1-3 to exempt for 
individual customers, turn this option off. 

Note: You can also set a single sale as tax exempt by clicking the ñTax Exemptò 
button on the POS screen. 

Department Options Tab  

 

The following describes the fields on this screen. 

Field Definitions 

Department For 
Class Fees  
Repair Parts and 
Labor,  
Rental Fees and 
Late Fees 

In these fields, enter the department numbers to be used when any of these 
charges are added to a POS ticket. 

Require 
Department for 
Unlisted Items 

Check this box to require the department to be specified when entering an unlisted 
item on a POS sale. 
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Pr inting Tab  

 

The following describes the fields on this screen. 

Field Definition 

Print Barcode 
Numbers on 
Receipts 

Check this box to print the barcode number as well as the description for each item 
on a receipt.  This can be helpful for returns, so you know exactly what items the 
customer bought, even if the product description is ambiguous. 

Print Customer 
Address on Receipt   

Check this box to print the customerôs address on the POS receipts. 

Print Customer 
Phone Number on 
Receipt   

Check this box to print the customerôs home phone number on the POS receipts. 

Print Discounts 
Rounded to 
Nearest Percent   

Check this box to print receipts with the discounts rounded to the nearest percent.  
This option does NOT affect any actual calculations. 

Print masked 
customer copy of 
credit card receipt 
on TM-U200  
(using 1-ply paper) 

If you use the Epson TM-U200, it is highly advised that this box be checked if 
using either PCCharge or PCAuthorize software. This forces the printer to hide the 
credit card number on the customerôs copy of the receipt. 
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Field Definition 

Print masked 
MERCHANT copy 
of credit card 
receipt on TM-T88 
(or on both copies 
of a TM-U200 using 
2-ply paper) 

If using a TM-T88 printer, this option masks the credit card number on the portion 
of the receipt the merchant keeps  

If using a TM-U200 printer and 2-ply paper, it masks the credit card number on the 
merchant and customer copies. 

Print Item Count Check this box to print the total number of items purchased on the receipt. 

Automatically 
Check ñPrint As 
Invoiceò on new 
sale 

If this option is checked, the ñPrint As Invoiceò button will be automatically checked 
whenever you start a new sale. This option is useful if you use a full-size piece of 
paper for all of your invoices instead of using a receipt printer.   

Print Store 
Charge/Credit 
Account Balance 
on Receipt? 

Check this box to print account balances on customer receipts. 

Print how many 
copies of receipt? 

Set the number of copies of receipts to automatically print after each transaction. 

Print Mail labels on 
2.25ò Labels   

Check this box if you are printing Eltron/Zebra mailing labels on the 2.25ò x 1.25ò 
labels.  If this option is off, it will assume you are using 1ò x 3ò labels. 

Mail Labels 12-
point Font   

Check this box to print mailing labels with a 12-point font instead of the default 10-
point font.  Note: This option only affects Zebra/Eltron label printers. 

Print Store Name 
on Barcode Labels   

Check this box to print your store name on barcode labels. 

Print Customer 
Address on Repair 
Label   

Check this box to print the customerôs address on repair labels. 

Print Vendor Part 
Number on 
Barcode Label 

Check this box to print the preferred vendorôs part number on barcodes. 

Date Code 
Encoding   

If you leave this field blank, the date codes printed on barcode labels will use 
numbers for the data.  For example, October 7, 2001 will be encoded as 100701.  
If you enter a string of 10 unique characters, they will be used as a substitution 
code for the date encoding.  For example, if you use ñABCDEFGHIJò as your code, 
the above date will be encoded as ñBAAHABò. 

Eltron/Zebra 
Horizontal Offset   

This setting allows you to move the print on your barcode labels.  Enter a positive 
number (such as 25) to move the printing to the right, enter a negative number 
(such as -25) to move the printing to the left. 

Use Black 
Headings in HTML 
Reports   

Check this box to display HTML reports with black table headings. To print with 
black headings you must change a setting in Internet Explorer.  In IE select 
Tools>Internet Options and go to the Advanced tab.  Scroll down to the Printing 
section and check the ñPrint background colors and imagesò box. 
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Inventory Tab  

 

The following describes the fields on this screen. 

Field Definitions 

Auto Barcode 
Number 
Generation 

Use these options to automatically generate unique barcode numbers when 
entering new products on the Edit POS Products screen.   
 
In the ñPrefixò field, specify a unique prefix (such as the store zip code).  In the ñ# 
of Additional Digitsò field, specify how many digits (after the prefix) you want to 
include.  The ñLast # Usedò field tracks the ending digits of the last number 
generated. (If you want the numbering to start at a specific number, enter it here).  
Thereafter, TRS will increment each new barcode by one and keep track of the 
last number used.  
For example, using the settings in the screen above, the next barcode generated 
will be 9722300005. 

Disable Low 
Stock / Out of 
Stock Warnings 

Check this box to turn off the low on stock or out of stock warnings that pop up 
when that item is sold on a POS ticket. 

Hide Costs When 
Entering 
Reordered 
Products 

This option relates to the Enter Reordered Products function (on the Inventory 
menu).  If this box is left unchecked, the message box at the end that specifies the 
new quantity in stock will display the cost.  If this box is checked, the cost is not 
shown. 
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Field Definitions 

Allow non-case-
sensitive 
scanning 

Check this box to accept barcodes in either upper or lower case in the Kit 
Creation, Orders, and POS screens. A product matching in either case will be 
accepted.  This feature is useful for resolving the problem of Num Lock always 
reversing the case of your barcodes. 

Disable Historical 
Inventory Level 
Tracking? 

Check this box to disable inventory tracking.  Disabling inventory tracking affects 
numerous features in TRS such as running inventory reports for prior dates or 
viewing a history of changes for any item.   

Because of the serious ramifications of changing this option, you will be prompted 
to enter a special password you must obtain from JMM Technical Support. When 
you check this box, a warning displays.  If you answer ñyesò to proceed, a 
reference code number displays.   You must provide the code number to a JMM 
Technical Support Specialist who will use it to generate a unique password to 
enter here to disable this option. 

Defaults for New 
Products 

Use these settings to specify the default values for certain fields in the POS 
Products database when entering new products. 

Restrictions for 
New Products 

Require Department ï Check this box to require a department for all new products 
entered in TRS.  

Drop-Down Only ï Check this box to require the department be selected from the 
drop-down list.  You will not be able to type in the department number. 

Require Vendor, Part# and Cost ï Check this box to require a Vendor, Part# and 
Cost for every new product.  You can override this with a password when desired. 

Only add new products via ñNew Product Screenò  (disables using ñ+ò sign to add 
new products) ï Check this box to only use the New Products screen for entering 
new products.  The New Product screen makes it easier to enter all the necessary 
fields for new items.   

Disallow Zero 
Cost when 
Receiving 
Inventory 

Check this box to require a cost (not zero) when receiving/checking in items in 
inventory. If checked, you will have to enter a cost other than zero when adjusting 
inventory in POS Products and receiving/checking in items on the Orders tab or in 
Enter Reordered Products (on the Inventory menu). 
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Customer Rewards Tab  

This screen allows you to set up a customer rewards program for your store. 

 

The following describes the fields on this screen. 

Field Definitions 

Money/ Volume 
Accumulation 
Printing 

To print a message at the bottom of each receipt with the accumulation total(s), 
check the appropriate box(es). Use the ñPrefixò and ñSuffixò fields to specify what 
the message will say.  The Prefix is printed before the amount, and the suffix is 
printed after.  For example:  If you want the receipt to say, ñYou have accumulated 
$35.67 in spending.ò enter ñYou have accumulatedò in the Prefix field and ñin 
spending.ò in the Suffix field. 

Money/Volume 
Accumulation Goal 

Set the goals for your customer rewards program.  In the Goal Amount field, enter 
the amount of money or product volume that a customer must accumulate in order 
to earn the reward.  Check the ñEnabledò checkbox to enable the reward. 
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Field Definitions 

Reward Type 

Select one of the 3 reward types.  If you select ñMessage Onlyò, TRS will pop up a 
message to the salesclerk when the goal is reached. 

If you select ñGift Cardò, TRS will issue a free gift card to the customer when the 
goal is reached.  If you select this option, another option will appear which will 
allow you to specify the amount of the gift card. 

If you select ñCustomer Discountò, when the goal is reached TRS will set up a 
standing discount in their customer record which will apply to future POS sales.  If 
you select this option, two additional options will display prompting you to specify 
the amount of the discount, and an optional expiration date for the discount.  

If you check the box labeled ñClear Accumulation When Goal Reachedò, TRS will 
subtract the goal amount from the customerôs accumulation when the goal is 
reached.  It is highly recommended that you check this box.  Otherwise, TRS will 
continue to offer the reward with every POS sale once the goal is reached. 

Popup/Receipt 
Message 

Enter a message to pop up for the salesclerk when the goal is reached.  Likewise, 
Receipt Message specifies a special message to print on the customerôs receipt 
when the goal is reached.  Both of these options are available, regardless of the 
reward type. 
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Accumulations  

 

The following describes the fields on this screen. 

Field Definitions 

Disable Customer 
Accumulations 

Check this box to disable accumulations for the customer rewards program 
(remember this can be set on each individual computer in the store). 

What Accumulates 
Toward Rewards? 

Check the Money and/or Volume box next to the items that should be included in 
the accumulations for the customer rewards program.  

Do Not Allow  
Accumulations for 
Discounted Items 

Check this box to prevent TRS from adding discounted items to a customerôs 
accumulations. 
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Discounts  

 

The following describes the fields on this screen. 

Field Definitions 

Discountable? 
Check these boxes to define items that are discountable. Those items designated 
as non-discountable cannot be modified by editing or discounting them on a POS 
ticket. 
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Misc. Options Tab  

 

The following describes the fields on this screen. 

Field Definitions 

Require Clerk 
Logon   

Check this box to require salesclerks to log on each time they start a POS sale 
(see page 119).  Set up Clerk ID in Security>Edit 
Employees/Clerks/Salespeople (see page 241). 

Note: If you are using PC Charge version 5.10.0 or later you must set up the 
cashier accounts in PC Charge and use the Send Cashier Credentials option when 
processing credit payments. You must check this box to require the clerk to logon 
when they start a POS sale and their Clerk ID must match the name in the PC 
Charge cashier accounts setup. 

Require Clerk 
Password   

Check this box to require salesclerks to enter their password each time they log on 
to start a POS sale (see page 119). Note: To set each clerkôs password select 
Security>Set Clerk Password from the TRS menu (see page 245). 

Clerk Logon 
Selected From List   

Check this box to require salesclerks to select their Clerk ID from a list (see page 
119).  Otherwise, they will be prompted to type in their login name.  Set up Clerk ID 
in Security>Edit Employees/Clerks/Salespeople (see page 241). 

If typed in, make 
sure it exists in 
clerkôs list. 

Check this box to require the clerk login to be verified as a valid clerk set up in 
Security>Edit Employees/Clerks/Salespeople (see page 241).  
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Field Definitions 

Make Continuous 
Login apply to POS 
Sales and other 
clerk selection pop-
ups. 

When using continuous login and this box is checked, any POS sales or other 
instances where a clerk ID would be required will automatically assume the ID of 
the security code of the person continuously logged in. 

Prompt for POS 
Category 

If you check this box, you will be prompted to select a category for the sale each 
time a POS sale is started.  Categories are set up in Edit Lists>POS Categories.   

Always Use The 
Following For This 
Station 

You can enter a category in this field to be used for every POS sale at this station. 

Use The Following 
For Key To The 
Web Import   

The value entered in this field will be included on every POS sale record imported 
from your ñKey To The Webò website.  This field is optional ï helps track, sort and 
report web orders separately from store orders. 

Automatically 
Finish Saleé 

If you check this box, you will not have to press the ñFinish Saleò button to 
complete a sale (see page 125).  The sale will automatically ring out when enough 
money has been tendered.  

Allow cash back on 
gift cards? 

Check this box to allow cash back on a partially used a gift card.  If you leave it 
unchecked, the balance must remain on the card for use at a future time. 

Hide Overrung 
POS Sales in 
Customer History 

If you check this box, overrung (voided) sales will not appear in any customerôs 
history. 

Detailed Credit 
Card tender and 
Misc. Tender types 

Check this box to use detailed credit card and/or miscellaneous tender types.  
These are set up in Edit Lists>Tender. 

Serialized Auto 
Commission 
Calculation 

To have TRS calculate commissions for sales in the Sales tab, select the Basis 
from the fields displayed and enter the ñCommission Percentageò.  The 
commission will be calculated by multiplying the Basis by the specified percentage. 

Prompt for missing 
phone number on 
POS Sales 

Check this box if you want to be prompted, when starting a new POS sale, whether 
to enter a phone number if it is missing from the customer record. 

Prompt for missing 
email address on 
POS Sale 

Check this box if you want to be prompted, when starting a new POS sale, whether 
to enter an email address if it is missing from the customer record. 

Jump to last sale 
on Review POS 
when finishing sale 

Check this box to automatically refresh the data for the Review POS function when 
each POS sale is finished.  NOTE: This feature may slow down some systems 
and, therefore, may be turned off in POS>Options>Misc. tab.  

Disable POS 
Screen Scrollbar 

This setting only affects users running 800 x 600 resolution. This option will disable 
TRS from having a scroll bar on the POS screen.  

Mark class 
enrollments as paid 
when adding to 
POS 

Check this box to automatically mark a customerôs enrollment record Paid (ñTò) 
when you add their class fees to a POS ticket. 

Show Popup When 
Customer has  
Store Credit 

Check this box to enable the ñCustomer has a store credit availableò popup 
message. 
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Field Definitions 

Do you use gift 
certificates or gift 
cards? 

Check Gift Certificates or Gift Cards.  This setting will affect which buttons appear 
on the POS screen. 

Select card or 
certificate each 
time (Use Only) 

Check this box to add the options of Gift Card or Gift Certificate on the POS screen 
when taking a gift certificate or gift card for payment.  This feature is only needed 
during the transition from using gift certificates to gift cards when you are still 
redeeming existing gift certificates.  Once you switch to exclusive use of gift cards, 
you can uncheck this box. 

Customizing the Function Keys  

If you would like to change which functions are associated with buttons on the POS screen, 

select POS> Customize Function Keys from the TRS menu.  A dialog box displays allowing 

you to change the function key mapping. 

To change a key mapping, enter the number of the function that you want to assign to the 

function key.  The key on the right shows you the numbers to enter for each function.  For 

example, if you want the F2 key to map to the Total function, then you would enter the number 9 

in the box labeled F2.  When you are finished changing the key mappings, select ñOKò to save 

the changes or ñCancelò to cancel the changes. 

WARNING  Do not use this feature if you are using a programmed POS Keyboard.  Results 

will be unpredictable. 
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Chapter 3  

Customers  

Initial Setup  for Customers  

Before entering new customers define the following drop down lists that are used on the 

Customers tab. 

¶ Cities (typical cities in which your customers reside) 

¶ Zip Codes (typical zip codes in which your customers reside ï may be used in Fast Zip 

Lookup) 

¶ Customer Classifications (optional classifications you may designate for a customer such 

as club memberships)  

¶ Custom Taxes (optional tax definitions) 

Access these lists by selecting Edit Lists from the TRS menu and click on the appropriate option.  

Refer to Edit Lists on page 14 for instructions for adding, editing and deleting from lists.  

In addition, certain preferences and options can be defined.  Define the following in 

Edit>Preferences: 

¶ Default State (you may set a default state that will pre-fill in the address of new 

customers) 

¶ Fast Zip Lookup City Name (defines the capitalization of automatic entries in the City 

Name field when using Fast Zip Lookup) 

¶ Inactive Status (set the system to automatically clear inactive status when a customer has 

activity) 

Refer to the Preferences topic on page 22 for more details about TRS Preferences. 

Several parameters are set in POS>Options, as follows: 

¶ In the POS>Options>Taxes tab, indicate the Tax Exempt Customer Default (you may set 

the ñWhen customer is exempt from Tax 1, make them exempt from all taxesò default).  

This box is automatically checked when you install the system.  

¶ In the POS>Options>Taxes tab, set the Tax rates, as appropriate. 

¶ Refer to Taxes tab on page 29 for more information. 

¶ In POS>Options>Cust. Rewards and POS>Options>Accumulations define you storeôs 

customer rewards program and the types of products and services that may accumulate.  

Refer to the Cust. Rewards and Accumulations tabs starting on page 35 for more 

information. 
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Customer s Tab  

 

Field/Button Descripti ons  

The following describes the fields and buttons on the Customers screen. 

Field/Button Definition 

First Name, Last 
Name, Address, 
City 

Enter the customerôs name and address information.  

Select the city from the drop down list (set up in Edit Lists>Cities).  You can 
type in the city if it is not listed in the drop down. 

Jump to Cust # 
Button 

Click this button to enter a customer number or scan a keytag to bring up a 
customer record. 

Company Enter the customerôs associated company. 

Fast Zip Lookup 
Enter the zip code in this field and press TAB. If the zip code is set up in your 
zip code list (Edit Lists>Zip Codes) the city and state will automatically fill in 
(as defined in Edit>Preferences). 

State 
Enter a 2-character abbreviation for the State.  A default can be set for this field 
in Edit>Preferences. 

Zip Code Enter a 5-digit zip code, the longer zip+4 zip code, or a postal code.   

Country Enter the customerôs country. 

Mail Label Button 
Click this button to print a mailing label for this customer directly to the label 
printer. 
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Field/Button Definition 

Barcode Button 
Click this button to print a label with a barcode of the customerôs number and 
the customerôs name, account number and your store name on it.  Youôll be 
prompted whether to print a date code on it.  

Email Enter the customerôs email address. 

Home Telephone 

Enter the customerôs home phone number. If this field is left blank, the system 
will warn you the phone number is missing (and prompt you whether to add it) 
when you create a new repair, serialized sale, lead, store account, special 
order, or class enrollment for the customer.  

Work Telephone Enter a second phone number for the customer. 

Date Added 
This date is set when the customer is added to your database for the first time.  
It can be manually changed at any time. 

Last Activity Date 
This date is updated every time the customer record is impacted (such as 
making a purchase, bringing in a repair or enrolling in a class).   

Birthday 
Optional: Enter the customerôs birthday.  Although a complete date, including 
year, is stored, it is recommended (for easier searching) that you enter the same 
year (such as 2000) for each customer. 

Classification 

Optional: Select a classification from the drop down list (set up in Edit 
Lists>Customer Types).  These are user-defined classifications, up to 10 
characters long. For example, you could use the field to track how the customer 
got into your customer database, such as LE for leads, SA for sale, RE for 
repair, or MA if the customer asked to be put on your mailing list. 

Spare 1, Spare 2, 
Spare Checkboxes 

Optional: Extra fields you can use to store additional information about 
customers.  The labels on these fields can be changed in Edit>Screen 
Designer>Edit Properties.   

Note:  If you upgraded from version 2, the Spare Check field will contain data 
from the ñInterested In Classesò checkbox from that version. 

POS Tax1 Exempt, 
Tax2 Exempt, Tax3 
Exempt 

Use these checkboxes to designate a customer as tax-exempt, or exempt from 
specific taxes and not others.  When you start a new POS sale for this 
customer, it will ask you if this sale is to be tax-exempt.  If so, all of the items will 
ring up as non-taxable, as defined by these fields.  The ñWhen customer is 
exempt from Tax 1, make them exempt Tax2 and Tax 3 alsoò setting in POS-
>Options>Taxes further defines the tax exempt setup.  This setting is ñonò by 
default, so to select tax exemptions separately for the 3 taxes, turn this option 
off.   

POS Discount 
Use this field to set an ongoing discount for a customer.  When you start a new 
POS sale for this customer, you will be prompted whether this sale is subject to 
the set discount.  If so, all of the items in that sale will receive the discount. 

Expires 
Enter the expiration date for the above POS Discount (optional). Once the date 
entered has passed, the discount will not be offered when ringing up a sale for 
the customer. 

Inactive 

Check this box for an inactive customer.  You can still enter sales, etc. for this 
customer, but the software will not print or export mailing labels for them, or add 
them to email lists.  In Edit>Preferences you can set TRS to automatically clear 
the Inactive Status on a customer record if there is any new activity for them 
(see page 22). 
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Field/Button Definition 

Label Button 
This button prints a label directly to the label printer with the customer name and 
any information in the Notes field. Typically, youôd use this function to print a 
label if you have an alternate shipping or mailing address in the ñNotesò field. 

Notes 
Enter additional notes about the customer (common uses are clubs they belong 
to or a different ship-to address). 

Pop Up? 
Check this box to display the contents of the Notes field in a pop-up message 
when you start a new POS sale for this customer using E-Z Search.  (It will also 
pop up if you use E-Z Search or Jump to Customer # on this screen.)  

Credit Limit, 
Terms 

Use these fields to establish a line of credit for your customer.  Credit Limit is 
the maximum total combined balances on all credit accounts.  Terms are the 
number of days that they have to pay off any charges. 

Bad Check 
Check this box to specify a customer has written a bad check.  In the future, if 
that customer tries to pay with a check, a warning will display. 

Accumulations 
Dollars/Volume 

This field is updated automatically by TRS.  It tracks how much the customer 
has accumulated in dollars spent and volume purchases (such as yardage, 
etc.).  Please see page 35 for more information. 

Assign Card Button 

Click this button to assign the barcode (or magnetic strip) on a customer loyalty 
keytag to this customer.  You can then use the keytag to scan the customer 
number instead of searching for the customer record.  See the ñCustomer 
Spending/Volume Accumulationsò topic below. 

Keytag Number 

This is the customer loyalty keytag number if one is assigned to a customer.  
The field will be blank if no keytag has been assigned, or you can delete an 
existing number to un-assign one. 

Note: The keytag barcode must begin with the upper-case letters, ñCLC.ò 

Wish List Button Click this button to access the gift registry (see page 60 for more information). 

Special Pricing 
Button 

Stores a list of specific items (with price and expiration date) this customer may 
purchase for a special price. 

Custom Tax 
Select the Custom Tax. Custom taxes are set up in Edit Lists>Custom Tax.  
See the ñCustom Taxesò topic on page 51 for more information. 

Tax Exempt 2 & 3 
Use these fields (and the Tax Exempt checkbox) to indicate any tax rates from 
which this customer is exempt.   

Show History 
Button 

To display the customerôs history on the right of the screen, click this button.  
See the ñCustomer History Screenò topic on page 47 for more information. 

Adding Customers  

To add a new customer click the + (add) button on the database toolbar.  Refer to the Field 

Definitions above for specific information about each field.  When you are finished entering the 

information, save it by clicking the *(save) button on the database toolbar. 

Modifying/Deleting Customers  

Refer to page 6 for detailed instructions for editing records. Refer to page 6 for information 

about deleting records. 
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WARNING   If you delete a customer from the database, all sale, repair, lead, and enrollment 

records for that customer will be deleted.  This data will be lost forever.  Any 

reports (other than Point Of Sale) will not include these deleted records.  Be 

absolutely certain sale, repair, lead, or enrollment records for that customer are 

no longer needed.  When a customer is deleted, their Point Of Sale records will 

remain in the database, but they will no longer be linked to the customer.   

Customer History Screen  

Display a customerôs history records by clicking the ñShow Historyò button.  The right side of 

the Customer screen will list a complete history of the customerôs activity (sales, repairs, leads, 

class enrollments, accounts, special orders and POS sales).  Jump directly to any of the records 

listed by double-clicking the entry in the list.   

  

Click on the ñHide Historyò button to hide the history.    
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You can also resize the individual lists of the history screen by dragging the dividing lines with 

the mouse.  

 

Hover over the dividing line until the mouse cursor changes to a double-arrow, left-click and 

drag down on that line to resize the display. 

E- Z Customer Search  

The ñEZ Customer Searchò button on both the Customer screen and the POS screen is a quick 

way to search for a particular customer.  To begin the search, click the ñE-Z Customer Searchò 

button.  The Phone Number prompt appears. 

 

If you have the customer's telephone number, enter it or a portion of it (the last four digits are 

sufficient and avoids errors if numbers were entered both with and without dashes).  Any 

customers who match that search will display.  If there are none, the Customer Name prompt 

appears.   

You can leave the phone number blank and either press Enter or click ñOKò and the Customer 

Name prompt will display. 
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Enter the customer's last name (or a portion of it).  Any customers whose last name matches the 

entry will display. 

 

If the desired customer is listed, double-click on the entry and the customer will be displayed on 

the screen.  If the correct customer is not listed, click the ñCancelò button.  You will be prompted 

whether to add this customer.   

If no matches are found, you will be prompted whether to add the customer.  

You can change the order of these search questions.  To search by last name first, in Edit> 

Preferences check the Search Last Name before Phone Number in E-Z Customer Search 

checkbox (shown on the following screen). 

 

Customer Spending/Volume Accumulations  

TRS will keep track of your customersô accumulations of dollars spent and volume (such as 

number of yards or fat quarters) purchased.  This can be used as an incentive program (customer 

rewards).  When a customer reaches a certain goal of dollars spent or volume purchased, you 
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could issue the customer a gift card, store credit, gift certificate, coupon, or other incentive, and 

start their accumulation again at zero.  

Setting Goals for Accumulations  

If you use the customer accumulations for a customer loyalty program, you can set a goal for 

accumulations and the ñrewardò offered in POS>Options>Cust. Rewards (see page 35 for more 

information about defining rewards).  You can set the goal level and special parameters, such as 

pop up messages, receipt messages and whether to allow discounted items to be accumulated.  

When the reward is met, you can have TRS display a message on the screen  (such as customer 

has earned a free fat quarter),  issue a free gift card as a reward or give the customer a discount in 

their customer record with an optional discount expiration date.  For more information about 

setting up accumulation goals, please see POS>Options>Cust Rewards on page 35 and 

POS>Options>Accumulations on page 37. 

Set Up Eligible Products  

To put this feature into practice, you must indicate which inventory items are eligible for these 

accumulations. On the Inventory>Edit POS Products screen, specify whether each product is 

eligible for the money accumulation and/or volume accumulation (shown on the screen below).   

 

 

Once you have defined products that are eligible, TRS will take over from there and 

automatically add to the customersô accumulations with every purchase. 

Set Up Eligible Accumulations  
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In addition to designating which products in your inventory may be accumulated toward a 

customer reward, you can define other options: 

¶ What, in addition to POS products, may be accumulated 

¶ Disable accumulations  

¶ Whether discounted items may be accumulated 

Go to POS>Options>Accumulations to define these options. 

Viewing a Customerôs Accumulations 

 

Each customerôs current accumulations will be displayed on the Customers tab.  These totals can 

be edited; however, it is recommended that you let TRS handle these fields automatically. 

Adding Accumulation Messages to Receipts  

You can have TRS automatically print messages at the bottom of the POS receipts, notifying the 

customer of how much they have accumulated in spending and/or volume.  Please see page 35 

for more details on setting up these messages. 

Customer Loyalty Cards/Keytags  

Customer loyalty cards or keychain tags are small plastic cards with barcodes on them you can 

distribute to your customers.  You can assign the barcode to a customer and scan it instead of 

searching the database for the customer.  If you make the card/keytag part of a customer loyalty 

rewards program, your customers will be happy to use them. 

Assign the loyalty card or keytag to a customer by clicking on the ñAssign Cardò button on the 

Customer screen and scanning the barcode on the keytag. The card number will subsequently 

display in the Keytag# field.  Once the keytag has been assigned, you can scan it instead of 

searching for the customer..  

JMM Software sells custom-printed customer loyalty cards and keytags guaranteed to work with 

TRS.  Please call or check the website (www.jmmsoftware.com) for pricing.  Be aware, if you 

buy them elsewhere, JMM will not guarantee they will work with TRS.    

NOTE: If you do decide to purchase them elsewhere, make sure that the barcodes on them 

begin with the letters ñCLCò in upper case. 

Custom Taxes  

In addition to the three sales tax rates set in POS>Options>Taxes, TRS supports an unlimited 

number of additional tax rates in Custom Taxes.  These taxes are set up in Edit Lists>Custom 

Taxes.  Just like sales tax 1-3, custom taxes will be calculated for eligible items as defined for 

each item in Inventory>POS Products (according to the tax rates selected).  
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You can assign one custom tax per customer on the Customer screen by selecting it from the 

drop-down screen. You can change it by selecting a different custom tax or remove it by 

selecting that field and pressing ñBackspaceò or ñDeleteò on your keyboard. 

In addition to setting a Custom Tax up ahead of time for a customer, you can also do it on the fly 

for a particular POS Sale, by clicking the "Set Custom Tax" button on the POS screen. 

Tax Exempt Customers  

You can also use Custom Tax to track different Tax-Exempt definitions.  To do this:   

¶ In Edit Lists>Custom Taxes, set up all the different reasons that a customer could be Tax 

Exempt (i.e. Resale, US Government, etc.) 

¶ Assign each of these Custom Tax items a 0% rate.   

Make any Tax Exempt customers exempt from Tax1-Tax3, but set their Custom Tax to one of 

these 0% items.   

Using this method, TRS will not charge them any tax, but it will keep track of the total sales 

subject to these special Custom Taxes. In this way, TRS will track the amount of tax exempt 

sales and the reason they were tax exempt. Use POS>Reports>Custom Tax to track each 

custom tax collected and the ñsubject toò amount. 

Customer Reports  

The following reports are available from POS>Reports in the POS>Options>Taxes: 

¶ Biggest Spenders (a list of your best customers based on dollars spent for a specified 

period of time) 

¶ Items Purchased by This Customer (a list of items this customer has purchased for a 

certain period of time) 

Refer to Viewing and Printing Reports on page 12 for more information. 

Special Searches for Customers  

To perform a special search, select the search from the Special Searches>Customers menu 

(shown below).  Most of these searches will result in a ñfound setò displayed on the customers 

tab (refer to page 11 for details on using a found set).  Some searches result in an answer or 

option displayed on the screen.  Each special search for customers is discussed below. 
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By  Amount Spent  

Use this special search to find all customers who have spent a certain amount (through POS) 

over a given period of time.  Select Special Searches>Customers>By Amount Spent from the 

TRS menu.  Enter the date range for which you would like to total the customersô spending and 

the minimum amount the customers must have spent to result in the search.  

Who has bought this item?  

Use this special search to find all customers who have purchased a particular item (through POS) 

within a certain period of time.  Select Special Searches>Customers>Who has bought this 

item? from the TRS menu.  Enter the date range for which you would like to search and 

enter/scan the barcode number for the product.   

Has this customer bought this item?  

To determine whether a customer has purchased a particular item, bring up the desired customer 

on the Customers tab.  Select Special Searches>Customers>Has this customer bought this 

item? from the TRS menu.  Scan or enter the barcode of the product.  TRS will tell you whether 

the customer has purchased the item.  If they have, an option to view the sale displays.  

 

Who has taken classes?  

Use this special search to find all customers who have enrolled in classes at your store.  Select 

Special Searches>Customers>Who has taken classes? from the TRS menu.  Enter the date 

range for which you would like to search. 
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Who has taken a particular class?  

Use this special search to find customers who have taken a certain class within a defined period 

of time.  Select Special Searches>Who has taken a particular class? from the TRS menu.  

Enter the date range for which you would like to search. 

Who has rented something?  

Use this special search to find customers who have rented something from your store (in a 

Rentals module transaction) within a certain period of time. Select Special Searches>Who has 

rented something? from the TRS menu.  Enter the date range for which you would like to 

search. 

Who has a machine not recently serviced?  

Use this special search to find customers who do not have a repair record (in the Repairs module) 

since a date defined by you. Select Special Searches>Who has machine not recently serviced? 

from the TRS menu.  Enter the date from which you would like to search. 

Who has bought items in a particular department?  

Use this special search to find all customers who have purchased any item in a selected 

department (through POS) within a certain period of time.  Select Special 

Searches>Customers>Who has bought items in a particular department? from the TRS 

menu.  Enter the date range for which you would like to search and the desired department 

number. If you enter a major department number (100, 200, 300, etc.) you will be prompted 

whether to include all sub-departments. 

Who has bought items by description?  

Use this special search to find all customers who have purchased an item matching a certain 

description (through POS) within a certain period of time.  Select Special 

Searches>Customers>Who has bought items by description? from the TRS menu.  Enter the 

date range for which you would like to search and any part of the item description.  

By Birthday Month  

Use this special search to find all customers with a birthday in a certain month. Select Special 

Searches>Customers>By Birthday Month? from the TRS menu.  Enter the number of the 

desired month (i.e. 1=January, 2=February, etc.). 

Whose email has changed?  

Use this special search to find all customers whose email address has changed for a certain date 

range.  Select Special Searches>Customers>Whose email has changed? from the TRS menu.  

Enter the date range for which you would like to search.  
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Customer Super Search  

 

The Customer Super Search is a powerful tool that allows you to build a search for a group of 

customers step-by-step, based on multiple parts of the database.  It allows you to see the results 

of your search each step of the way, and to add customers to or subtract customers from the 

result, until you have the exact set of customers you want.  The following illustrates a typical 

super search. 

For example, to send a special mailing to: 

¶ All customers who have had a machine in for repair in the past year, 

¶ And have not purchased a new machine in the past year, 

¶ And do not reside out of state. 

Always begin by clearing out the results of any previous super searches by selecting Special 

Searches>Customer Super Search>Start Over. 

For this example, the first step is to add all customers who have had a machine repaired in the 

past year.  To do this, on the Repairs tab, click ñComplex Searchò.  Use the Search Assistant to 

bring up all repairs that have Date Completed greater than one year ago today (illustrated in the 

following diagram).   

 

When the search is complete, TRS will display how many repairs it found.  
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Select Special Searches>Customer Super Search>Add Current Found Set To Result (while 

still on the Repairs tab).  The number of customers you are about to add to the special search 

results displays and prompts whether you want to continue.  Click ñYesò. 

Next, a summary of the new results display and you are given the option to either keep the 

results or revert back to the previous results. Click ñKeep the new resultsò.  A confirmation that 

the results were accepted will display. 

The next step is to remove all customers from the current set of results that have bought a 

machine in the past year.  Go to the Sales tab and click ñComplex Searchò.  Use the Search 

Assistant to bring up all sales that have Date Purchased greater than one year ago today.   

 

When the search is complete TRS will display how many sales it found 

Select Special Searches>Customer Super Search>Remove Current Found Set From Result 

(while still on the Sales tab).   Click ñYesò and then ñKeep the new resultsò. 

The last step is to remove all customers from the current set of results that do not reside in the 

state.  Go to the Customers tab and click ñComplex Searchò.  Use the Search Assistant to bring 

up all customers where their state does not equal your state.   

 

When the search is complete TRS will display how many customers it found. 

Select Special Searches>Customer Super Search>Remove Current Found Set From Result 

(while still on the Customers tab).   Click ñYesò and then ñKeep the new resultsò. 
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Now that you have finished building your search, select Special Searches>Customer Super 

Search>Done ï Make Result The Current Customer Found Set.  TRS will display the final 

number of customers found.   

NOTE You MUST complete this step to make the Customer Super Search results the current 

customers ñfound setò before you can use the results. 

Now, you can use this ñfound setò of customers to print mailing labels, print a phone list, send a 

bulk email, etc., (just like any other found set of search results). 

At any time during the Customer Super Search process, you can check and see the number of 

customers in the current found set by selecting Special Searches>Customer Super 

Search>Check Current Results from the TRS menu. 

Merging Customer Records  

Occasionally you may find you have the same person in your customer database twice.  Often, 

both customer records will have a history (linked sales, repairs, classes, etc.).  TRS has the 

ability to remove one of the customer records, and at the same time, merge the histories of the 

two customers into the one customer record you are keeping.  You can do this two ways: 

Using Merge Two Customers Utility  

Find the two customers that you want to merge and make a note of their customer numbers. 

Manually edit the customer record you want to keep, adding any desired information from the 

customer record you will be deleting.  (Only the history fields merge; therefore, you should 

evaluate the informational fields ï phone numbers, email address, and so forth - and perform any 

needed changes on the customer account you will be keeping.) 

Select Maintenance>Merge Two Customers from the TRS menu.  You will be prompted to 

enter the customer number of the customer to keep, then the customer to delete. 

A final confirmation prompt displays the two customers you are merging.  Click ñYesò to 

complete the task. 

 

Using Duplicate Customer Find/Merge  

This method finds the duplicate customer records for you.  You can run the program just to find 

out how many duplicates are in the system, or to create a list of them, as well as have the system 

automatically merge the records for you. 

In the automatic merge feature, the system keeps the smallest customer number.  The history 

transactions will be merged together into that record.  The system does not merge the 

informational fields, such as address, phone numbers, or email address.  You can use the 
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duplicates list report to determine any changes youôd like to make to the customer that will be 

kept before running the merge.  

To run the program select Maintenance>Duplicate Customer Find/Merge from the TRS 

menu.  Following the screens that appear, select the desired options.  You can perform a strict or 

a loose search, and from that display how many duplicates exist, print a report listing the 

duplicate records, or have the system automatically find and merge the duplicates found by the 

search.  You may also specify a maximum number of merges to perform each time you run this 

program. 

Mailing Labels  

Labels Supported by TRS  

Laser or Ink Jet Printer 

TRS mailing labels are designed to print on all AveryÈ ñ30 per sheetò laser or ink jet labels 

(sized 1" x 2 5/8").  Some of the compatible Avery® label product numbers are 5160, 5260, 

5160B, 5970, 5971, 5972, 5980, 5982, 5983, and 5660.   

Label Printer 

The other option for printing mailing labels is on the Zebra/Eltron LP2622, LP2722, or LP2824 

label printer. If you are printing on the Zebra printer, use the 2.25" x 1.25" labels (part# 800522-

125) 

Printing a Single Mailing Label  

If you have a compatible label (or barcode) printer, access the desired customer in the Customers 

tab.  Click the ñMail Labelò button and the mailing label will print. 

  

Printing or Exporting a Set of Mailing Labels  

You can print mailing labels for any found set of customers, sales, repairs, or leads.  You can 

also export that list of customer names and addresses to a DBASE (.dbf) file. These labels may 

be extracted from Customers, Sales, Repairs or Leads, as well as the Customer Super Search.   

Search for customers, sales, repairs, or leads to get the set of customers for the mailing list 

(considered a found set).  To export your entire mailing list, go to the Customers screen, select 

the ñQuick Searchò button, and then click ñOKò, without entering any search parameters.  
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To export the file, select File>Export Mailing Labels for Found Set from the TRS menu.  You 

will be prompted whether to exclude customers with email addresses.  In the ñSave Asò dialog 

box indicate where to save the file.  You can save it to your hard drive, a USB flash drive, or if 

the file is small enough, to a floppy drive. 

To print the labels, select Reports>Mailing Labels for Found Set from the TRS menu. You 

will be prompted whether to exclude customers with email addresses.  The next prompt is, ñSkip 

how many labels?ò.  Typically, leave this field blank to print all the labels; however, if some of 

the labels have already printed, you can specify how many to skip so duplicates do not print. 

Follow the printing prompts to print on your label or laser/ink jet printer.  

For more information about Found Sets see page 11. 

If you search from any database other than customers, TRS will automatically weed out any 

duplicate customers when printing the mailing labels if a single customer record is attached to 

multiple detail records (i.e. one customer with multiple repairs).  It also automatically sorts the 

mailing labels in zip code order, as may be necessary for bulk mailing.  To sort by zip codes 

when searching from the customer database, please see page 8. 

Avery Label Spacing  

Some printers (some inkjet printers in particular), do not space Avery mailing labels correctly.  

This is due to the printer driver not reporting the correct number of pixels per inch to the 

application.  To fix this, manually set the number of vertical pixels per inch following these 

steps: 

¶ Select Edit>Label Spacing>Manually Set Label Spacing from the TRS menu. 

¶ Click ñYesò at the warning, and again at the instructions. 

¶ You may be told that the file VPPI.TXT does not exist and asked if you would like to 

create it.  If so, choose ñYesò. 

¶ Enter the number of vertical pixels per inch into the notepad window that comes up.  If 

you donôt know this, try starting at the DPI rating of your printer.  If you do not know the 

DPI rating for your printer, then try starting at 500. 

¶ Select File>Save from the Notepad window. 

¶ Select File>Exit  to exit Notepad. 

Try printing the mailing labels again.  If the labels are too far apart, repeat the steps above, but 

decrease the number of vertical pixels per inch.  If they are too close together, increase the 

number.  Repeat until the labels are printing with the correct spacing. 

To set the label spacing back to automatic, select Edit>Label Spacing>Reset Label Spacing to 

Automatic from the TRS menu. 

Interface to DAZzle Shipping Software  

TRS interfaces to DAZzle shipping software (used by Endicia Internet Postage) from the 

Customers tab.  You must be signed up for Endiciaôs Premium service and DAZzle must first be 

installed in the following directory:  C:\Program Files\Envelope Manager\DAZzle. 

To send a customer address to DAZzle, access the desired customer in the Customers tab and 

press Ctrl-Alt -E on the keyboard.   
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Customer Wish Lists (Gift Registry)  

TRS has the ability to store wish lists for customers.  This works like a gift registry at a 

department store.   

Creating/Editing/Printing  

To create a wish list, or edit an existing one, access the customer on the Customers tab.  Then, 

click on the ñWish Listò button. 

 

The Wish List Editor displays (shown below). 

 

To add a new item to the customerôs wish list, click the ñAdd New Itemò button.  Enter or scan 

the productôs barcode number, enter the quantity desired and any notes the customer would like 

entered about the product. 

To remove an item from the wish list, select the item with the mouse so that itôs highlighted in 

blue, and click the ñDelete Current Rowò button.  

To print the wish list, click the ñPrintò button.  Indicate whether or not to print the ñalready 

purchasedò quantities.   

Selling Items on the Wish List  

If a purchase is being made from a wish list, you will need to know the customerôs number from 

the top of the wish list, as shown below. 
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When you ring up the sale on the POS screen, click the ñGiftò button as shown next. Enter the 

customer number of the gift recipient from the top of the wish list printout.   

 

NOTE This may be done either before or after scanning the items, but it must be done before 

the sale is completed. 

The Wish List will be updated to reflect those purchases when the sale is completed. 

Special Pricing  

You can set up special pricing on select products for a customer. Click the ñSpecial Pricingò 

button and the following screen displays. 

 

Enter or scan each item with special pricing. Enter the special price and a date the offer expires.  

If you leave the Expires field blank, the special price will be in effect until you delete it from this 

screen. 
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Chapter 4  

Serialized Sales   

Initial Setup for  Serialized S ales  

Before entering sales of serialized items, define the following drop-down lists used on the Sales 

tab. 

¶ Store (optional designation of store where this sale took place) 

¶ Type (typical types of sales such as sewing machines, sergers, or cabinets) 

¶ Makes (makes of machines you sell) 

¶ Models (models of machines you sell) 

¶ Method of Payment (optional - methods of payment accepted by your store) 

Access these lists by selecting Edit Lists from the TRS menu and click on the appropriate option.  

Refer to page 14 for instructions for adding, editing and deleting from lists.  

TRS will automatically calculate the total commission to be paid for a sale.  The manner in 

which commission is calculated is set up in POS>Options>Misc. Options.  In addition, each 

salesperson must be set up in Security>Edit Employees/Clerks/Salespeople (see page 241). 

You can set up custom footers to print on the bottom of Sales invoices.  Select File>Edit Sale 

Footer from the TRS menu and enter the desired text.  Refer to Footers on page 26 for more 

information. 
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Sales Tab  

 

Field/Button Descriptions  

The following describes the fields and buttons on the Sales tab. 

Field/Button Definition 

Customer Displays the customer name for this sale.   

Date Purchased The date on which the product was purchased.   

Price The price of the product.  

Discounted Price 
The discounted price charged for the product (if appropriate). If commissions 
are calculated, they will be based on this price. 

Store 
For multiple stores, use the drop-down menu (set up in Edit Lists>Stores) to 
select the store where the product was purchased.   

Type 
Specify the type of product the customer bought.  Use the drop-down menu to 
select the Type (set up in Edit Lists>Sale Types). 

Make, Model 
Using the drop-down menus, select the make and model of the product 
purchased. Refer to page 17 for more details about setting up Makes and 
Models to properly integrate with serialized inventory.  

Serial # 
This field stores the serial number of the product purchased.  If you are using 
the Serialized Inventory function in TRS, use the ñSelect From Listò button to fill 
this field. Refer to page 177 for more information about serialized inventory. 

Select From List 
Button 

Click this button to select a serial number from the Serialized Inventory list.  
(You must have selected the Make and Model from the drop-down menus 
above.)  The available serial numbers display; click on the one for this sale.  
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Field/Button Definition 

Trade-In Make and/or model of the trade-in, if appropriate. 

Trade-In Value Enter the amount of credit for the trade-in. 

Total Commission 
Either enter the total commission for the sale or let TRS calculate it.  Specify the 
manner in which commission is calculated in POS>Options>Misc. Options.   

Salespersons,  
% of Commission 

Use these fields to keep track of who sold the product.  It supports up to three 
salespeople, and tracks the percentage of the total commission for each one.  
Use the drop-down menu to select the salespeople (set up in Security>Edit 
Employees/Clerks/Salespeople).  Enter the % of commission (up to 100%) 
each salesperson is entitled to for this sale.  For example, if two people are 
evenly splitting the commissions on a sale select each of their IDs from the 
drop-down menus and enter 50 beside each for the % of Commission.  

Tax Rate 

This field stores the sales tax rate that was in effect when the machine was sold.  
When entering a new sale, it is automatically pre-filled, according to the default 
tax rate.  You can set the default tax rate by choosing Edit>Preferences from 
the TRS menu.  Although this field is filled in automatically, you can change it 
manually. 

Method of Payment 
Indicate how the customer paid for the product (drop-down selections are set up 
in Edit Lists>Methods of Payment).   

Notes Enter any notes about this sale. 

Cost  
Show/Hide Button 

This field stores the wholesale cost you paid for the product. TRS will supply the 
amount here if it is stored in the system.  See page 255 for more information.  
To display the cost in this field, click ñShowò; to mask the cost, click ñHideò. 

Warranty Ends Enter the ending date of the warranty for the product. 

Warranty Enter the details about the warranty. 

Return This 
Machine Button 

Click this button to process a return on the machine.  Refer to the Returning a 
Machine topic on page 66 for more information. 

New Repair for 
This Machine 
Button 

Click this button to set up a Repair for this machine.  This Repair tab displays 
with the Customer, Make, Model, and Serial Number fields pre-filled with the 
information from this record. 

Take Deposit 
Button 

To set up a layaway account for this sale, click the ñTake Depositò button. 

Deposit Amount 
If a deposit was received (described in the previous field) the amount will display 
here. 

Invoice Button 
Click this button to create an invoice for the sale.  The system will prompt 
whether to generate in HTML or plain text.  Click ñYesò for HTML format; click 
ñNoò to print a plain text format. 

Add To POS Ticket 
Button 

Click this button to add this sale to a POS Ticket.  

Adding Sales  

You must first find the correct customer on the Customers tab.  Once a customer is displayed on 

the screen, click the ñFor This Customer:  Enter Newé  Saleò button.   
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The Sales tab displays with the Date (current dayôs date) and the customerôs first and last name 

automatically filled in.  Fill in the appropriate fields; see Field Definitions above for further 

information. When you are finished click the *(save) button on the database toolbar. 

NOTE The new sales record that you enter will automatically be linked to the customer 

currently displayed on the Customers tab.  Make sure that the correct customer is 

displayed on the screen. 

If you selected the serial number of the item sold from the list displayed when you click the 

ñSelect from Listò button, that item will be removed from inventory.  If your serialized items are 

set up correctly in both POS Products and Serialized Inventory and integrated through the 

Models list editor, that serial number will be removed from Serialized Inventory and the POS 

Products inventory will be decreased.  Refer to Serialized Inventory (page 181) and POS 

Products (page 157) for more information. 

Modifying or Deleting Sales  

Refer to page 6 for detailed instructions for editing records. Refer to page 6 for information 

about deleting records. When you delete a sale record you will be prompted whether to add that 

machine back into inventory. 

Returning a Machine  

To create the credit transaction and delete (optional) the sale record for the machine, use the 

ñReturn this Machineò button.  A POS ticket is created with a credit transaction for the machine.  

At the prompt, indicate whether to deduct the trade-in value before tax (if you deducted the 

trade-in before tax on the original sale, enter ñYesò).  You also will be prompted whether to keep 

or delete the sales record, as well as whether to add the machine back into inventory.  Process the 

POS ticket as usual.    

Sales Reports for Serialized Items  

To print a report, select it from the Reports>Sales menu (shown next).  The report will display 

on the screen.  For information about viewing and printing text-based reports, refer to page 12. 
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NOTE: These reports only access serialized sales data (based on records on the Sales tab).  

These are not Point Of Sale reports.  

Sales Summary  

This report shows the success of each serialized product that you sell.  It lists how many of each 

product sold, the percentage of total number of sales, the total revenue from each product, and 

the percentage of total revenue.  Select Reports>Sales>Sales summary from the TRS menu.  

Enter the date range and whether to report revenues after trade-ins.   

Sales Report by Salesperson  

This report shows productivity and profitability of salespeople over a period of time.  It lists the 

number of machines each salesperson sold, the percentage of total number of sales, the total 

revenue from each salesperson, and the percentage of total revenue.  Select 

Reports>Sales>Sales report by salesperson from the TRS menu. Enter the date range and 

whether to report revenues after trade-ins.   

The number of sales for a person may display a fractional number.  This is because sales are 

sometimes split between 2 or 3 salespersons. 

Commission Report for a Salesperson  

This report shows the commissions a selected salesperson made for a specified time period.  It 

lists each sale made, the commission he/she earned, the date of the sale, the customer's last name, 

the machine sold, and the percentage of the total commission received for each sale, as well as 

the total commission.  Select Reports>Sales>Commission report for a salesperson from the 

TRS menu. Enter the salespersonôs ID and his/her full name when prompted. Enter the desired 

date range. 
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Chapter 5  

Repairs  

Initial Setup for Repairs  

Before entering repairs define the following drop-down lists used on the Repair tab. 

¶ Accessories (typical accessories left with the machine such as foot pedal, power cord and 

bobbin case). 

¶ Service Requests (typical services such as clean/oil/adjust).  

¶ Work Performed (typical work performed, similar to Service Requests). 

¶ Technicians (a list of technicians who repair machines in your store). 

Access these lists by selecting Edit Lists from the TRS menu and click on the appropriate option.  

Refer to page 14 for instructions for adding, editing and deleting from lists. When setting up 

Service Requests and Work Performed in Edit Lists, be sure to enter both a Short Name and a 

Description for each one.  When working in the Repairs tab, the Short Name will display in a list 

for you to choose from and the Description(s) will be entered on the repair ticket. 

Several parameters need to be set up in POS>Options, as follows: 

¶ In the POS>Options>Department Options tab, enter the Departments to be used for 

repair parts and repair labor (refer to page 30).  Departments are set up from the Edit Lists 

menu. 

¶ In the POS>Options>Taxes tab, indicate which tax rates are applicable for repair parts 

and repair labor (refer to page 29 for more details). 

¶ In the POS>Options>Discounts tab, put a check in the checkbox if repair parts and/or 

labor are discountable (refer to the Discounts Tab on page 38for more details). 

¶ In the POS>Options>Accumulations tab, put a check in the checkbox if repair parts 

and/or labor are to be accumulated toward money or volume for customer rewards (refer 

to the Accumulations Tab of page 37 for more information). 

You can set up custom footers to print on the bottom of Repairs invoices and claim checks.  

Select File>Edit Repairs Footer from the TRS menu and enter the desired text.  Refer to page 

26 for more information. 
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Repairs Tab  

 

Field/Button Descriptions  

The following describes the fields and buttons on the Repairs tab. 

Field/Button Definition 

Jump to repair # 
Enter the Repair number and press Enter to jump directly to a certain repair. The 
repair number is printed on repair claim checks and invoices.   

Date In The date the customer brought the machine in for repair (defaults to current date).  

Checked In By Enter the name or initials of the clerk that checked in the repair.  

Make, Model, 
Serial # 

Enter the make and model of the product to be repaired, along with the serial 
number.  (These fields may be pre-filled if you originated the repair from the Sales 
tab or clicked the ñNew Repair for Same Machineò button on this tab.) 

Store 
Optional: The store (or other location) the repair came from.  Use the drop-down 
menu to select the store (set up in Edit Lists>Stores).  

Service Request/ 
Select Button 

Enter the work requested for the machine.  A list of typical services (including 
parts and labor estimates) can be set up in Edit Lists>Repair Service Requests.  
Click the ñSelectò button to choose services from that list.  You can also enter 
customer comments, details of what is wrong with the machine, etc.  Note: To 
both select from the list and enter customer notes, use the ñselectò button first, 
then click in the Service Request box to add additional text. 
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Field/Button Definition 

Accessories 
Checked In/ 
Select Button 

Enter which accessories the customer left with the machine.  A list of typical 
accessories can be set up in Edit Lists>Repair Accessories. Click the ñSelectò 
button to choose accessories from that list. Note: To both select from the list and 
manually enter notes, use the ñselectò button first, then click in the Accessories 
Checked In box to add additional text. 

Labor Estimate, 
Parts Estimate 

Enter an estimate for the work to be done in these two fields.  These estimates 
can be filled in automatically, based on the Service Request (see Service Request 
field definition above). 

Promise Date  

Enter the date the repair was promised to be completed.   

This field is used to create a Reminder ï if the date promised is prior to the current 
date and the Date Completed (below) is empty, this record will be included in 
Reminders.  See Daily Reminders, page 25 for more information. 

Date Completed The date the repair was completed.   

Picked Up Date The date the machine was picked up. 

Technician 
Enter the technician who repaired the machine (drop-down selections are set up 
in Edit Lists>Technicians).   

Work Performed/ 
Select Button 

Enter the work the technician actually performed on the machine.  A list of typical 
services (including labor prices) can be set up in Edit Lists>Repair Work 
Performed.  Click the ñSelectò button to choose services from that list.  Note: To 
both select from the list and enter notes, use the ñselectò button first, then click in 
the Work Performed box to add additional text. 

Warranty Ends Enter the ending date of the warranty for the work performed. 

Parts, Labor, 
Price 

Use these fields to enter the parts used, the labor charges, and the price for each 
part and labor item.  Refer to the Entering Parts and Labor on the Repair Screen 
topic on page 73. 

Scan Part,  
Search for Part 
Button 

To enter the part(s) used for this repair, either scan the part barcode, search for 
the part by description or enter it manually in the Part and Price fields. See 
Entering Parts and Labor on the Repair Screen on page 73 for more information. 

Scan Labor 

To enter the labor charges, either scan or manually enter the barcode in the Labor 
and Price fields.  If you entered Work Completed with labor prices already set up, 
those items will be pre-filled with that information.  You can add or modify it as 
desired. See Entering Parts and Labor on the Repair Screen on page 73 for more 
information. 

Tax Rates 

These fields store the parts and labor tax rates that were in effect when the repair 
was done.  When entering a new repair, these fields are automatically pre-filled, 
according to the default tax rates.  You can set the default tax rates by choosing 
POS>Options>Taxes or Edit>Preferences from the TRS menu.  Although these 
fields are filled in automatically, you can change them at any time by entering a 
different value on the repair form.  

Method of 
Payment 

Specify how the customer paid for the repair.  

Totals  The totals fields are calculated automatically.  No input allowed. 
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Field/Button Definition 

Enter Estimates 
Button 

Click this button to enter estimates for this repair.  You can use this button instead 
of editing the estimate and date promised fields above. Once entered, the next 
steps in the transaction are offered ï You will be prompted whether to create a 
POS ticket or email the estimate to the customer. 

Email Estimate, 
Send Completed 
Email, and Email 
Pickup Reminder 
Buttons 

You can send email notices to the customer with their estimate information, with 
notice of completion and/or reminders to pick up their machine by clicking the 
appropriate button.   

Note: The customer must have an email address in the Customers tab and the 
JMM Email Suite must be installed and configured for this feature to work. 

Make Repair 
Complete Button 

Click this button to close out a repair.  You can use this button instead of editing 
the record to enter the Date Completed.   You will be prompted whether to create 
a POS ticket or email a completed pickup reminder for this repair. 

Invoice Button 
Click this button to create an invoice for the repair.  The system will prompt 
whether to generate in HTML or plain text.  Click ñYesò for HTML format; click ñNoò 
to print a plain text format. 

Repair Label 
Button 

Click this button to print a repair label on the label printer. It will print the repair 
number, make, model and serial number in addition to the customerôs name and 
phone number. It can include the customerôs address if that option is selected in 
POS>Options>Printing.  

Claim Check 
Button 

To print a claim check on the receipt printer, click this button. You can print this to 
either a regular or receipt printer. 

Add to POS 
Ticket Button 

Click this button to add this repair to a POS Ticket. 

New Repair for 
Same Machine 
Button 

Click this button to set up another repair for this machine.  The Customer Name, 
Make, Model and Serial Number fields will be pre-filled. 

Take Deposit 
Button 

To set up a layaway account for this repair, click this button. 

Adding a New Repair  

From the Customer s Tab  

You must first find the correct customer on the Customers tab.  Once a customer is displayed on 

the screen, click the ñFor This Customer:  Enter Newé Repairò button.   

 

The Repair tab displays with the Date In (current dayôs date) and the customerôs first and last 

name automatically filled in.  Fill in the appropriate fields; see Field Definitions above for 

further information. When you are finished, click the *(save) button on the database toolbar. 
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NOTE The new repair record that you enter will automatically be linked to the customer that is 

currently displayed on the Customers tab.  Make sure that the correct customer is 

displayed on the screen. 

From the Sales or Repairs Tab  

If the customer purchased the machine from you, you can automatically start a repair for the 

machine from the Sales tab.  To display the sale, either ñQuick Searchò for the serial number (or 

other pertinent data) or find the customer on the Customers tab and double-click on the sale in 

the ñShow Historyò list.  Click on the ñNew Repair for Same Machineò button, the repair screen 

displays with a new repair started.  The date in, customer, make, model, and serial number will 

all be entered automatically.   

Similarly, if the customer had the same machine repaired by your store in the past, you can bring 

up that previous repair, and click on the button labeled ñNew Repair for Same Machineò. 

Modifying or Deleting Repairs  

Refer to page 6 for detailed instructions for editing records. Refer to page 6 for information 

about deleting records. 

Repair Email Notifications and Other Special Buttons  

You can send email notifications to your repair customers with an estimate on their repair or to 

let them know (or remind them) the repair is complete and they can pick up their machine. Use 

the buttons near the bottom of the Repairs tab (shown below). 

 

NOTE The customer must have an email address in the Customers tab and the JMM Email 

Suite must be installed and configured for this feature to work. 

Entering Parts and Labor on t he Repair Screen  

There a numerous ways to enter Parts and Labor details as described below. 

 

Enter Line Items Manually  

You can enter each part and labor item by typing descriptions and prices in the Part and Labor 

boxes below the óScanô fields.   
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Scan Pa rts and/or Labor  

You can set up repair parts and/or labor codes in your product inventory database 

(Inventory>Edit POS Products) and use barcodes/item IDs to enter parts and/or labor.  Use the 

ñScan Partò or ñScan Laborò fields to scan in a barcode or type in a code.  For parts, it will 

prompt for the quantity and decrease the inventory for that item.  For labor, set up the item with 

the ñDonôt Track Inventoryò box checked since labor does not have a quantity that can be 

counted or stored. Please see the Inventory chapter (page 149) for details on entering items into 

your product inventory database. 

Labor Prices from Work Performed  

If you enter the work performed using the ñSelectò button, the labor charges set up for those 

tasks in Edit Lists>Repair Work Performed  automatically fill the Labor and Price fields.   

 

You can add and/or modify the labor (and parts) lists on this screen if necessary.   

Using the ñSearch for a Partò Button  

You can search for a part by description or part # by clicking the button labeled ñSearch for a 

partò.   

If you select Description, enter part of the description.  A list of matching items from your POS 

Inventory Products will display.  Double-click on the desired item and it will be entered into the 

repair screen.   

If you select Part #, the following screen displays.  This search option accesses the POS Vendor 

Products. 
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Begin entering the vendorôs part number ï as each character is entered, a list of parts beginning 

with those characters display.  You can enter the whole number or enter part of it and scroll 

through the list and select the desired part.   

NOTE The Part Finder will not allow you to enter a part into the repair if the item in Vendor 

Products has a UPC code but is not in your POS Products inventory. Either enter that 

part manually on the repair ticket or edit the Vendor Product and remove the UPC code. 

If the part that you select is set up in your POS Product inventory, it will be tracked by 

decreasing the inventory count and the price and cost will carry over to the POS Ticket.  You 

may also select parts that are not set up in your POS Product inventory.  In other words, the item 

doesnôt need to be set up in inventory and have a barcode assigned before using it in your 

repairs. This is very beneficial if you donôt want to have thousands of repair items in your POS 

Products that you donôt normally sell individually. However, any items used in repairs that are 

not in your POS Products database cannot be tracked. Because they only exist in Vendor 

Products, there is no inventory count assigned or tracked. 

Finishing the Repair  

As prices are entered on the repair, TRS will compute the taxes for each category (parts and 

labor).  When the repair is complete you can add it to a POS ticket and the Picked Up Date will 

automatically fill. Optionally, you can print an invoice for your customer with the ñInvoiceò 

button. The details of the parts and labor for the repair will list on this invoice. Only the 

summary of each category will print on the POS receipt. 

Repair Reports  

To print a report, select it from the Reports>Repairs menu (shown below).  The report will 

display on the screen.  For information about viewing and printing text-based reports, refer to 

page 12. 
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Repair  Report by Technician  

Run this report for a list of repairs by date range, summarized by technician.  It details how many 

repairs each technician completed, the percentage of total repairs that he/she did, the total 

revenue in parts and labor that each technician brought in, and the percentages of total revenue in 

parts and labor.  To create this report select Reports>Repairs>Repair report by technician 

from the TRS menu.  Select or enter a date range.  The report displays on the screen.  Print as 

desired. 

To - Do List  

Run this report for a list of all repairs that have not been completed.  For each repair, it shows the 

repair #, date in, customer name, phone number, make, model, serial number, store, and service 

request.  To create this report select Reports>Repairs>To-Do List from the TRS menu.  Select 

the order you would like the repairs listed (by date in, or date promised). The report will display. 

Special Searches for Repairs  

To perform a special search, select the search from the Special Searches>Repairs menu (shown 

below).  This search will result in a ñfound setò displayed on the Repairs tab (refer to page 11 for 

details on using a found set).   

 

Overdue (Past Promise Date)  

Use this special search to find all repairs that are overdue ï that is the date promised has passed 

and the date completed field is blank.  Select Special Searches>Repairs>Overdue (past 

promise date) from the TRS menu.  The number of records found displays.  

  

 



 

Leads TRS11 Page 77 

Chapter 6  

Leads  

Initial Setup for Leads  

Before entering new leads define the following drop-down lists used on the Leads tab. 

¶ Demo Lengths (typical lengths of demos, such as brief, partial, full, phone) 

¶ Lead Statuses (typical status of leads, such as looking, on verge, contact) 

¶ Make (makes of sewing machines your store carries) 

¶ Model (models of sewing machines your store carries) 

Access these lists by selecting Edit Lists from the TRS menu and click on the appropriate option.  

Refer to page 14 for instructions for adding, editing and deleting from lists. 

Each salesperson must be set up in Security>Edit Employees/Clerks/Salespeople (see page 

241). 

You can set up custom footers to print on the bottom of quotes.  Select File>Edit Quote Footer 

from the TRS menu and enter the desired text.  Refer to page 26 for more information. 

Leads Tab  
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Field/Button Descriptions  

The following describes the fields and buttons on the Leads screen. 

Field/Button Definition 

Demo Date Date the machine was demonstrated. 

Customer 
Displays the name of this lead.  Even though they are not yet a customer, leads 
must be set up first on the Customers tab (to add the information into the TRS 
database). 

Make, Model 
Select the make and model of the machine that was demonstrated (drop-down 
selections are set up in Edit Lists>Makes and Models). 

Salesperson 
Select the salesperson who demonstrated the machine (drop-down selections 
are set up in Edit Lists>Salesperson). 

Demo Length 
Specify how extensive the demonstration was by selecting an option from the 
drop-down list (drop-down selections are set up in Edit Lists>Demo Lengths).  

Price Quote Enter the price you quoted to the customer for the product. 

Price Range Enter the customerôs shopping price range.  This is a 20-character-based field. 

Machine to Sell Machine the customer has to sell (not a trade-in), if any. 

Machine to  
Trade In 

Machine the customer has to trade in (if any). 

Status of Lead 
Enter the status of the lead (drop-down selections are set up in Edit Lists>Lead 
Statuses). 

Next Follow-up 
Date 

Specify a date youôd like to follow up on the lead.  If you fill in this field, you will 
be reminded when your leads are due for follow-up (refer to page 25 for more 
information on Daily Reminders). 

Hot Lead Check this box to indicate this is one of your ñhot leadsò.   

Notes Enter any additional information about this prospect. 

Contact Log 
To track the contact youôve had with this lead, enter notes in this field about 
conversations, cards mailed, etc. 

Print Quote Button Click this button to print a quote to give the customer. 

New Sale for this 
Lead Button 

Click this button to create a new sale based on this lead.  The Sales tab will 
display with the appropriate fields pre-filled. 

Adding a New Lead  

To enter a new Lead, you must first add this person in the Customers tab.  Enter as much 

information as you have about them, such as name, phone number, address and email. Once the 

customer is entered and still displayed on the screen, click the ñFor This Customer:  Enter 

Newé Leadò button. 
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The Lead tab displays with the Date In (current dayôs date) and the customerôs first and last 

name automatically filled in.  Fill in the appropriate fields; see Field Definitions above for 

further information. 

Modifying or Deleting Leads  

Refer to page 6 for detailed instructions for editing records. Refer to page 6 for information 

about deleting records. 

Searching  

You can easily find certain leads by using the Quick Search or Complex Search functions.  The 

Leads Quick Search screen is shown below. 

 

For example, to find your own set of leads, select your Clerk ID from the Salesperson drop-down 

list and click ñFindò.  The results of the search are a ñfound setò.  Refer to Found Sets on page 11 

for more information on how to use them. 

For more in-depth searches, such as finding leads for a certain Clerk who had a demo in the 

month of June, use the Complex Search function (illustrated in the following diagram).  
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Special Searches for Leads   

To perform a special search, select the search from the Special Searches>Leads menu.  This 

search will result in a ñfound setò displayed on the Leads tab (refer to page 11 for details on 

using a found set). 

Time to Follow Up  

Use this special search to find the leads equal to or past the Next Follow-up Date.  Select Special 

Searches>Leads>Time to Follow Up from the TRS menu.  Enter the salespersonôs code you 

would like to search for or leave this field blank to search for leads that need follow-up for all 

salespeople.  

NOTE Leads to follow up will also display on the Reminders screen (see page 25 for more 

information about Reminders).   
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Chapter 7  

Classes  

Initial Setup for Classes  

Before you begin selling classes, several parameters need to be set up in POS>Options, as 

follows: 

¶ In the POS>Options>Department Options tab, enter the Department to be used for class 

fees (refer to page 30).  Departments are set up in the Edit Lists menu. 

¶ In the POS>Options>Taxes tab, indicate which tax rates are applicable for class fees 

(refer to page 29 for more details). 

¶ In the POS>Options>Discounts tab, put a check in the checkbox if classes are 

discountable (refer to the Discounts Tab on page 38 for more details). 

¶ In the POS>Options>Accumulations tab, put a check in the checkbox if classes are to be 

accumulated toward money or volume for customer rewards (refer to the Accumulations 

Tab of page 37 for more information). 

Classes Tab  
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Field/Button Descriptions  

The following describes the fields and buttons on the Classes tab.  

Field/Button Definition 

Class Name 
Enter the name of the class, such as ñBeginning Sewingò or ñAdvanced 
Quiltingò. 

Jump To Class # 
Button 

To display a different class (for which you know the number), click this button 
and enter the desired class number. 

Description Enter a brief description of the class. 

Default Kit 
If there is a kit for the class, enter or scan the barcode number of the kit here.  
This field will automatically be pre-filled in Sections created for this class (it can 
then be overridden). 

Edit Info Sheet 
Button 

Click this button to enter a supply list or other details for the class.  The Info 
Sheet can be printed and/or emailed. 

Print Info Sheet 
Button 

Click this button to print the information sheet (if available) for this class. 

New Section For 
This Class Button 

Click this button to add a new section for this class. Every separate occurrence 
of a class (or each time you would collect a fee) is considered a section.  For 
instance, if you hold a beginning quilting or card-making class every month, set 
up the main details of the class in this tab and set up a new section for each 
monthly class. 

Upcoming Class 
List 

Click this button to display a list, by date, of all sections for classes available in 
the future. Select the one desired and the section screen will display. 

Section View 

Use these options to define (by End Date) how to display the sections offered 
for a class. 

Include Old Sections ï mark this option to show every section offered for the 
class, regardless of the dates offered. 

Show Only Current ï mark this option to show only sections that are currently 
offered (the dates offered have not passed). 

Adding Classes  

To add a new class, access the Classes tab and click on the + (add) button on the database 

toolbar.  Enter the appropriate information as described above.  Save the class by clicking on the 

* (save) button. 

Modifying or Deleting Cla sses  

Refer to page 6 for detailed instructions for editing and deleting records. 

WARNING   If you delete a class from the database, all sections and enrollment records for that 

class will be deleted and the enrollment record will be removed from the customer 

history.   
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Undelete Entire Class  

This TRS function restores a deleted class and all of its sections.  Select 

Maintenance>Undelete>Entire Class. 

 

A list of deleted classes will display.  Double-click the class to be restored. The selected class 

and all of its sections and enrollments will be restored. 

NOTE If the deleted classôs class number or sectionôs section number has been re-used for 

another class or section since it was deleted, you will no longer be able to restore the 

deleted one. 

Edit and Print Info Sheet Buttons  

Click the ñEdit Info Sheetò button to enter a supply list or other details of the class that can be 

printed or emailed to the customer.  The following screen displays: 

 

You can click the ñLimit width to 40 columnsò box to make the text easy to print on the receipt 

printer.  When you are finished, click the ñSave and Exitò button. 
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To print this information sheet, click the ñPrint Info Sheetò button.  You will also be prompted to 

print or email this sheet when you enroll someone in a section. 

Class Reports  

To print a report, select it from the Reports>Classes menu (shown below).  The report will 

display on the screen.  For information about viewing and printing text-based reports, refer to 

page 12. 

 

Enrollment List for Class Section  

Prints an enrollment list for any section in your class database.  It displays the names of each 

customer who is enrolled in the section, whether they have paid for the class, and their phone 

number.  The customers will be listed in alphabetical order.  To create an enrollment list, display 

a class section on the screen and then select Reports>Classes>Enrollment list for current 

section from the TRS menu.  Answer the alphabetic order and enrollment notes prompts.  The 

report displays on the screen.  Print as desired. 

List of All Classes and Sections Currently Scheduled  

Prints a list of all classes and sections that are scheduled.  It displays each class in your database, 

its description, and information about each section that is scheduled.  To create this report select 

Reports>Classes>List of all classes and sections currently scheduled from the TRS menu. 

Class Success Report  

Prints a report detailing the financial success of your classes.  It displays each class in your 

database, along with the number of enrollments and total revenue brought in by the class.  It also 

shows what percentage of total enrollments and total revenue each class contributed.  To create 

this report select Reports>Classes>Classes success report from the TRS menu. Enter the date 

range for the report. 

Special Searches for Classes  

To perform a special search, select the search from the Special Searches>Classes menu (shown 

next).  This search will result in a ñfound setò displayed on the Classes tab (refer to page 11 for 

details on using a found set). 
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Time to Cancel (Low Enrollment)  

Use this special search to find all classes with a low enrollment (the minimum number of 

students enrolled has not been met as of the Low Enrollment Cancel Date specified in the class 

section). 
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Chapter 8  

Sections  

Initial Setup for Sections  

For each class you must set up at least one section to enroll students.  A section is one full course 

of a class.  For example, if you have a single session class, you would set up one section for that 

class.  If you have a class that meets every week for 4 weeks, you would set up one section for 

that class.  However, if you offer the same class several times per year, you would set up one 

section each time the class is offered. 

Before entering sections, define the following drop-down lists used on the Sections tab. 

¶ Instructor (a list of instructors who teach classes in your store) 

¶ Method of Payment (optional - methods of payment accepted by your store) 

Access this list by selecting Edit Lists from the TRS menu and click Instructor.  Refer to Edit 

Lists page 14 for instructions for adding, editing and deleting from lists. 

Each salesperson must be set up in Security>Edit Employees/Clerks/Salespeople (see page 

241). 

You can set up custom footers to print on the bottom of Class confirmations.  Select File>Edit 

Class Footer from the TRS menu and enter the desired text.  Refer to page 26 for more 

information. 

If there is a supply list or other information to hand out as customers sign up for this section, set 

that up on the Classes tab by clicking the ñEdit Info Sheetò button. 
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Sections Tab  

 

Field/Button Descriptions  

The following describes the fields and buttons on the Sections tab. 

Field/Button Definition 

Price Enter the price for this class section. 

Maximum Students 
Enter the maximum number of students that may enroll in the section.  If you 
leave this field at 0, you cannot enroll anyone.  This can be useful if you are not 
yet ready for people to sign up.  Enter a value of 99999 for unlimited enrollment. 

Minimum Students Enter the minimum number of students needed to hold the class. 

Low Enrollment 
Cancel Date 

Enter the date to determine whether to cancel the class if the enrollment level 
does not meet the number entered in the Minimum Students field above.  This 
field is used to create a Reminder (see Daily Reminders, page 25, for more 
information). 

Instructor 
Select the instructor of the section (drop-down selections are set up in Edit 
Lists>Instructors). 

Location If desired, use this field to specify where the class will be held. 

Kit 
Enter the kit for the class (may be pre-filled from the Class record) if applicable.  
You will be prompted whether to add it to the POS ticket with the class fees. 

Start Date Enter the date the class starts.   
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Field/Button Definition 

End Date 
Enter the date the class ends.  It is important to enter a date in this field even if 
the class begins and ends on the same date (the section view on the Classes 
tab uses this field to determine if a class is current or old).  .  

Schedule Specify the days and times for this section (enter any text as desired).   

In-Store Notes 
Enter any extra information about the section.  These notes display in red on the 
screen and do not print on the class enrollment confirmation. 

Copy Section 
Button 

Click this button to copy/create a new section for this class with similar data.  A 
Sections screen displays with pertinent fields pre-filled.  Edit as necessary. 

Print Info Sheet 
Button 

Click this button to print the information sheet (class supply list, etc.) for this 
section. 

Email Notifications 
Button 

Click this button to send email to students in the class.  Choose from Reminder, 
Cancellation or Other messages.  Note: The customer must have an email 
address in the Customers tab and the JMM Email Suite must be installed and 
configured for this feature to work.  

Go to this class Click this button to display this class on the Classes tab. 

Enroll (name) in 
this Section Button 

Click to enroll the customer indicated on the button in this section. The 
Enrollment Form screen displays.  Those fields are defined below.  Also, refer to 
the Enrolling Customers in Classes topic on page 91. 

Email Confirm 
Button 

Click to email a class confirmation to the customer highlighted in the enrollment 
list.  Note: The customer must have an email address in the Customers tab and 
the JMM Email Suite must be installed and configured for this feature to work. 

Print Confirm 
Button 

Click this button to print a confirmation receipt for the customer highlighted in 
the enrollment list. 

Add to POS Button 
Click this button to create a POS ticket with class fees for the customer 
highlighted in the enrollment list. 

Move to Enrolled 
Button 

Click this button to move the customer highlighted in the wait list to the 
enrollment list. 

Copy Students 
Button 

Click this button to copy the entire section to a new section, including the 
enrolled students, the waiting list, or both. This is a quick, efficient way to enroll 
the same students repeatedly in monthly classes (such as block of the month or 
clubs). 

Go to selected 
customer Button 

To jump to the customerôs record, highlight the desired student in either list and 
click this button. 

Un-Enroll Selected 
Student Button 

To remove a student from a section, highlight her/him in the list and click this 
button. 

Edit Enrollment 
Button 

To make changes to the enrollment form, highlight the desired student and click 
this button. 

Add (name) to wait 
list Button 

If the section is full, you can add a customer to the waiting list by clicking this 
button.  Be sure the correct customer name displays on the button. 

Remove From Wait 
List Button 

Remove a customer from the section waiting list by highlighting the customer 
and clicking this button. 

Upcoming Class 
List 

Click this button to display a list, by date, of all sections for classes available in 
the future. Select the one desired and the section screen will display. 
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Field/Button Definition 

Enrollment Form Fields 

Paid Check this box to indicate the customer has paid for the class. 

Salesclerk Select the clerk from the drop down list. 

Method of Payment 
Specify how the customer paid for the class by selecting the method from the 
drop down list. 

Notes Enter any additional information about the customer or enrollment. 

Adding Sections  

To add a new section (instance of a class), you must first display the class on the Classes tab.  

The new section that you enter will automatically be linked to the class that is displayed; 

therefore, you must make sure that the correct class is displayed on the screen.  

Once the class is displayed on the screen, a new section may be added using one of two methods.  

The first is by switching to the Sections tab on the database notebook and clicking on the + (add) 

button on the database toolbar.  The second and easier way is to click the ñNew Section For This 

Classò button on the bottom left hand side of the class screen.  Once you have performed one of 

these two steps, you can fill in the fields as described above. When you are finished entering the 

information, save it by clicking on the * (save) button on the database toolbar. 

Copying a Section  

Another way to enter a new section is to copy it from an existing section of the same class.  

Bring up the section of the class you want to copy.  Click the ñCopy Sectionò button as shown 

below.  A new section will be created with the same details.   

 

Add details and modify fields as necessary.  Save the new section by clicking on the * (save) 

button on the database toolbar. 

Modifying or Deleting Sections  

Refer to page 6 for detailed instructions for editing records. Refer to page 6 for information 

about deleting records. 
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Undeleting a Class Section  

This TRS function restores a deleted class and all of its sections.  Select 

Maintenance>Undelete>Entire Section. 

 

A list of deleted sections will display.  Double-click the section to be restored. The selected 

section with its enrollments will be restored.   

NOTE Un-deleting a class or section will only work if the class/section number has NOT been 

reused by another class or section. 

Enrolling Customers in Classes  

You must first find the correct customer on the Customers tab.  Once a customer is displayed on 

the screen, go to the Classes or Sections tab and find the desired class/section.  When you have 

the section displayed, the Enroll button with the customerôs name on it displays,(as shown in the 

figure below).  Click on this button to enroll the customer. 

.  

You will be warned if this class has already started (or has ended).  If the class is scheduled for 

the future, the following enrollment screen displays. 
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Enter the desired information.  When you are finished, click ñOKò. Several prompts will appear 

ï you can: 

¶ Print the enrollment confirmation  

¶ Print a class info sheet (see page 83 for more information about class info sheets)  

¶ Send a confirmation email (see page 94 for more information about email notifications) 

¶ Add Class Fees to POS ticket (will create a POS ticket with class fees and mark this 

enrollment as paid) 

If the customer has an email address entered into their customer record, the system will prompt 

whether to send the customer an email confirmation.  This feature requires the JMM Email Suite, 

which can be downloaded from the ñCustomers Only Loginò section of the JMM Software 

website.  

Copying Students from On e Section to Another  

The ñCopy Studentsò button enables you to easily copy an entire section of enrolled students 

and/or students on the waiting list to another section of the same class. This is particularly handy 

for setting up Block of the Month (BOM) Clubs (or other recurring classes with same students). 

You can use this method by enrolling all the BOM customers just once, and then copy them all 

forward to the future months of the club. 

Modifying Enrollments  

To modify an enrollment, display the section that contains the enrollment that you want to 

modify. Highlight the desired customer in the list box and click the ñEdit Enrollmentò button in 

the lower right hand corner of the screen. 

The enrollment form (previous topic) will be displayed on the screen.  Make the desired changes.  

When you are finished editing the record, save your modifications by clicking the ñOKò button.  

If you change your mind and want to abandon the changes that you have made, click the 

ñCancelò button. 

Un - Enrolling Customers from C lasses/Waiting Lists  

You can un-enroll a customer from the section by selecting the desired customer on the 

enrollment list and clicking the ñUn-Enroll Selected Studentò button. You will be prompted 

whether to refund the class fees.  Select ñYesò to add a refund of the class fee to a POS ticket. 
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Likewise, if you would like to remove a customer from the waiting list, click on the ñRemove 

From Wait Listò button. 

Sorting the Enrollment/Waiting Lists  

You can change the display order of the enrollment and waiting lists by clicking on a column 

head.  For example, clicking on the Last Name heading will display the students alphabetically 

by last name. 

 

Adding Customers to a Class Waiting List  

If the section is full, you can add the customer to a waiting list.  Be certain the correct customer 

is displayed on the Customers tab, then click ñAdd to wait listò (shown below). 

 

The enrollment screen appears.  

 

 Enter the desired information.  When you are finished, click ñOKò. 

Clicking Last Name displays contents in 
alphabetical order by last name. 
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Sending Class Email Notifications  

 

Three options are available for sending custom email notifications for class sections.  You can 

send a class reminder, a class cancellation notice, or any other general email to all of the enrolled 

customers.  The class reminders and cancellation notifications can be customized with your own 

template.   

NOTE The customer must have an email address in the Customers tab and the JMM Email 

Suite must be installed and configured for this feature to work.  

Refer to the JMM Email Suite Help File for more information about using email notifications.  

Links to the JMM Email Suite and the manual can be found on JMM Softwareôs website on the 

Emailer page:  www.jmmsoftware.com/emailer.htm. 

 

  

 

http://www.jmmsoftware.com/documents.htm
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Chapter 9  

Accounts/Layaways  

Initial Setup of Accounts/Layaways  

Before entering accounts, define the following drop-down lists used on the tab. 

¶ Define each salesperson in Security>Edit Employees/Clerks/Salespeople (see page 

241). 

If you plan to allow customers to charge purchases to a store charge account: 

¶ Enter the Credit Limit $ and Terms (Days) for each charge customer on the Customers 

screen (see page 46). 

You can set up custom footers to print on the bottom of Account print-outs. Select 

File>Layaway/Account Footer from the TRS menu and enter the desired text.  Refer to page 26 

for more information. 

About Accounts and Layaways  

The Accounts/Layaways tab is somewhat different from the other TRS tabs ï it is primarily used 

only for receiving payments and viewing account activity.  Tasks such as setting up store 

accounts and creating transactions are typically and easily handled on the POS screen (layaways 

are discussed below).  

The instructions in this section for manually performing tasks on this tab should only be 

followed for initially implementing TRS.  For day-to-day transactions, store accounts (both 

charge and credit accounts) will be managed from the POS tab.  

Layaway Considerations  

Layaway accounts can be created a number of ways: 

¶ From the POS tab, for all items on a POS ticket, use the ñPut on Layawayò button. 

¶ From the Sales tab (for serialized items) use the ñTake Depositò button  

or add the item to a POS ticket and use the ñPut on Layawayò button. 

¶ From the Repairs tab use the ñTake Depositò button  

or add the repair to a POS ticket and use the ñPut on Layawayò button. 

Any layaway set up in the system will create a record in the Accounts/Layaways tab; however, 

layaways set up on the POS tab are handled very differently than those from ñTake Depositò 

buttons on the Sales or Repairs tab or those created manually on the Accounts/Layaways tab. 

There are different procedures to follow depending on how the layaway originated.  Each way is 

explained in this chapter.   
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NOTE It is recommended that your store decide which layaway method is going to be used 

and follow those procedures consistently. 

Accounts/Layaways Tab  

 

Field/Button Descriptions  

Following are field and button descriptions for the Accounts/Layaways tab.  Some of them 

(indicated below) refer only to store charges and some only to layaways. 

Field/Button Definition 

Date Started 
Date the account or layaway was started -- usually refers to the date the sale was 
made. 

Due Date 
Date payment is due on a store charge account.  It only displays when the ñStore 
Charge/Creditò checkbox is checked (see below), and the account has a negative 
balance.   

Description A description for this account.   

Notes 
Use this field to record any other information you may have about this layaway or 
account.  It allows a longer, more detailed description. 

Store 
Charge/Credit 

Check this box if this is a store charge or credit.  Leave it unchecked to designate a 
layaway. 



Accounts/Layaways TRS11 Page 97  

Field/Button Definition 

Salesperson 
Select either the person, from the drop down list, who made the sale or the person 
who opened the account.  The list of salespeople is set up in Security>Edit 
Employees/Clerks/Salespeople.  

Account Balance 
This field appears for store charges/credits only.  It is the current account balance 
for this account.  It is calculated automatically from the charges and payments 
made. 

Layaway Amount 
This field appears for layaways only.  It is the original amount of the purchase or 
the total amount needed for the purchase to be paid off. 

Payments 
Received 

This field appears for layaways only.  It is the total amount of payments that have 
been made toward the layaway.  This value is calculated automatically from the 
transactions. 

Balance Due 
This field appears for layaways only.  It is the amount of money that the customer 
still needs to pay on the layaway.  It is the layaway amount minus the payments 
received.  It is also calculated automatically. 

Print Account 
Button 

Click this button to print a statement of the account information. 

Jump To Acct # 
Button 

Click this button to enter another account number and display that account. 

Transactions 
Double-click on a transaction displayed in this section of the screen and if the 
transaction is linked to a POS sale, it will display that sale in Review POS. 

Enter Payment 
Button 

To enter a payment on the account, click this button.  Enter the details on the new 
payment screen.  When you click ñOKò a POS ticket will be created and displayed. 
Complete the transaction. 

Apply Payments To 
Sale Button 

This button is not typically used ï it is easier to perform this task from the POS tab 
(see page 106). This button only appears on store layaway accounts. When you 
are ready to close out the account and take the final payment, click this button. 
Enter the total payments received in the Debit Amount field and the other details as 
desired.  The transaction will be added to the POS ticket.   

Enter Charge 
Button 

This button is not typically used ï it is easier to perform this task from the POS tab 
(refer to page 106). This button only appears on store charge/credit accounts. To 
enter an additional charge amount to this account, click this button. 

Add Transaction to 
POS Ticket Button 

This button is not typically used ï it is easier to perform this task from the POS tab. 
Highlight a transaction and click this button to add it to a POS ticket. 

Edit Transaction 
Notes Button 

Highlight a transaction and click this button to edit or add notes to that line. 

Date Date the payment or charge was made. 

Amount The amount of the payment or charge. 

Clerk The clerk who entered the payment or charge. 

Notes Any other additional information about this payment or charge. 
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Layaways  

There are multiple methods of creating layaways in TRS.  A new layaway can be started from 

the Sales or Repairs tab (using the Take Deposit button), a new layaway can be started from the 

POS tab (using the Put on Layaway button) or one can be started manually from the 

Accounts/Layaways tab.  Any of these methods ultimately create a layaway account record 

where you can accumulate payments until the customer is ready to redeem the layaway (pay off 

the account and pick up the merchandise).  However, the procedures required to handle each 

method are very different. 

Typically, manually setting up and entering Layaways will only be done when you initially 

implement TRS (to set up existing accounts).  Once you are ñliveò on the system, you should set 

up or add layaway charges from the Sales, Repairs or POS tabs (explained below). 

Creating layaways on the POS tab may be the easiest method because the POS sale ticket is 

created at the beginning of the process  and essentially suspended to be recalled later when the 

layaway is redeemed.  The ñTake Depositò method requires you to go back and find the original 

record in Sales or Repairs and create the sale ticket in order to redeem the layaway.  Either 

method does the job! 

Adding New Layaways  

There are several ways a new layaway may be started: 

¶ From the POS screen. 

¶ From the Sales screen (for serialized items). 

¶ From the Repairs screen. 

¶ Manually on this screen. 

Follow the procedures below for the appropriate method. 

Adding New Layaways from the POS Screen 

TRS allows you to put any sale on layaway from the POS screen (including serialized sales and 

machine repairs).  Layaways created this way may be managed through the ñSuspended Sale 

Managerò where you can view a list of the items on layaway or delete the sale altogether.  You 

may also recall the POS ticket and modify it (add or remove items) and put it back on layaway.  

Creating the layaway account and redeeming the merchandise are both done from the POS 

screen. 

You can put a sale on layaway (including creating a layaway account and taking an initial 

payment) directly from the POS screen. You can layaway as many sales as you want and can 

keep them on layaway indefinitely 

NOTE Creating a layaway account from a POS ticket using the ñPut On Layawayò button is 

different than creating a layaway account either manually (using the Accounts/Layaway 

tab) or having one set up by taking a deposit from the Sales or Repairs tab.  Any 

layaway set up in the system will create a record in the Accounts/Layaways tab; 

however, only those set up through a POS ticket may be recalled using the ñLayaway 

Pickupò button on this screen.    
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Once you have entered all the items on the POS ticket to be put on layaway, click the ñPut On 

Layawayò button.  

 

The New Layaway screen displays with the total amount of the sale as the amount to layaway.   

 

Enter the clerk ID and notes, if desired.  

Next, youôll be prompted whether to take an initial down payment. If yes, the New Payment 

screen displays.   
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Enter the appropriate details.  The system will then create a new POS ticket for the amount of the 

payment.  Complete the sale as usual. 

The layaway account will show in the customerôs history (see the ñPicking Up (Redeeming) 

Layawaysò topic on page 103).   

To recall the ticket and modify the items use the ñLayaway Pickupò button.  Bring up the desired 

layaway, modify as necessary and then put it back on layaway by clicking the ñPut on Layawayò 

button. To view the items on or cancel (delete) a POS Layaway, go to Maintenance>Manage 

Suspended Sales/Layaways on the TRS menu (see page 140).   

Adding New Layaways from the Sales Screen 

Clicking the ñTake Depositò button on the Sales tab after you have entered the details of the 

serialized sale transaction automatically creates a layaway account for that transaction.   

Enter the Sale as usual (see page 63) and save it by clicking the on the * button.  At the ñAdd 

this sale to POS ticket?ò prompt, click ñNoò.  Click ñTake Depositò.  The New Layaway screen 

displays with the Date Started, Description, Salesperson and Layaway Amount fields pre-filled 

with data from the Sales tab.   

 

Enter the clerk ID and notes, if desired.  The New Payment screen displays.  

 



Accounts/Layaways TRS11 Page 101  

Enter the down payment amount and other details as appropriate.  The system will create a 

transaction for the deposit amount on a new a POS ticket (or add the transaction to an open 

ticket). Complete the POS sale as usual. 

As described in the ñLayawaysò topic above, you can also create a layaway and take a deposit 

for a serialized sale by adding this transaction to a POS ticket and using the ñPut on Layawayò 

button.  

Both the sale of the serialized item (sewing machine, vacuum, camera, etc.) and the layaway 

account will show in the customerôs history.  See the ñRedeeming Layaways Originating from a 

Deposit on Sales Screenò topic on page 105. 

Adding New Layaways from the Repairs Screen 

Clicking the ñTake Depositò button on the Repairs tab after you have entered the details of the 

repair automatically creates a layaway account for that transaction.   

Complete the Repair as usual (see page 70).  Click ñTake Depositò.  The New Payment screen 

displays. Enter the deposit amount and other details as appropriate.  The system will create a 

transaction to collect the deposit amount on a new a POS ticket (or add the transaction to an open 

ticket). Complete the POS sale as usual. 

You can also create a layaway and take a deposit for the repair by adding this transaction to a 

POS ticket and using the ñPut on Layawayò button.  

Both the repair and the layaway account will show in the customerôs history.  See the 

ñRedeeming Layaways Originating from a Deposit on Repairs Screenò topic on page 105. 

Manually Adding New Layaways  

It is important to note most layaway accounts will be created automatically in TRS by either 

taking a deposit on the Sales or Repairs tab or putting a POS sale ticket on layaway on the POS 

tab.  Manually setting up layaway accounts will usually only need to be done when you initially 

implement TRS in order to set up previously existing accounts.  

In the unusual event that you need to add a new layaway manually, find the correct customer on 

the Customers tab.  Once a customer is displayed on the screen, click the ñFor This Customer:  

Enter Newé Layaway/Charge/Creditò button.   

 

Because the new layaway record you enter will automatically be linked to the customer currently 

displayed on the Customers tab, make sure the correct customer is displayed on the screen.  The 

Account Selection dialog box displays (shown next).   
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Click the ñLayawayò button.  The New Layaway screen displays (shown below).  

 

Enter the desired information and click ñOKò.  You will be prompted whether to enter the initial 

down payment.  If you select ñYesò, the New Payment screen displays (below). 
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Enter the initial payment amount and other details as desired.   

The transaction will be added to the current POS ticket.  Since this is a manual entry, it is likely 

you are implementing TRS and establishing the record for a pre-existing account (not actually 

taking in a payment at this time), so you will need to cancel the POS sale ticket.  On the POS 

screen, click the ñCancel Saleò button and select the ñYes, but Override Acct Transaction 

Deletionò option (refer to the ñCanceling Account Transactions in POSò topic on page 116 for 

more information).  The layaway account will be set up and available for use as you go ñliveò on 

the system.  

Receiving Additional Payments on Layaways  

To enter a payment on a Layaway account (regardless of how it originated), access the account 

(double-click the appropriate account listed in History on the Customersô tab).  Click the ñEnter 

Paymentò button in the Transactions section of the screen (shown below). 

 

Enter the payment amount in the New Payment screen, and the clerk ID and any Notes (if 

desired).  When you click ñOKò, the system will create a new POS ticket with the payment 

transaction on it (or add the transaction to an open POS ticket).  Finish out the POS sale as usual. 

NOTE Payments on layaways must be entered on the Accounts/Layaways tab ï there is no 

way to originate the transaction on a POS ticket. 

Picking Up (Redeeming) Layaways  

The process of redeeming a layaway differs depending on how the layaway originated.  Layaway 

accounts that are set up automatically in TRS contain certain identifying text in the Description 

field, such as ñDeposit on Repairò or ñPOS Layawayò.  To determine how the layaway 

originated, display the customerôs history on the Customers tab (shown below).  The following 

example shows a list of Accounts for this customer (Accts section) and a cross reference to the 

tab where it originated.  
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Once the origin of the layaway account is determined, follow the instructions below for the type 

of layaway the customer is picking up. 

Redeeming Layaways Originating from the POS Screen 

To redeem a layaway originally set up in POS, go to the Point of Sale tab.  Without starting a 

new sale, click the ñLayaway Pickupò button.  
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Select the appropriate layaway from the list that displays.  When prompted to apply the payments 

made, click ñYesò.  The items put on layaway and all the payments will list on the POS ticket.  

Complete the sale as usual.  

Redeeming Layaways Originating from a Deposit on Sales Screen 

To redeem a layaway originally set up by taking a deposit on the Sales tab, access the original 

sale record from the Show History portion of the Customers screen (see page 47 for details).  The 

description in the Accts section usually has the information you need to determine the 

corresponding sale transaction (as shown below).  

 

Double-click the sale record and the customerôs sale transaction displays on the Sales tab. Click 

the ñAdd to POS Ticketò button.  Then select ñYesò on the ñApply the deposit already made?ò 

prompt.  The New Payment screen displays with the Payment Amount pre-filled with the total 

amount paid on this layaway.  Enter the rest of the details as appropriate.  

The system will create a POS ticket with the serialized sale transaction and the total payment 

transaction (or add them to an open POS ticket).  On the POS screen, click ñTotalò to display any 

balance due and complete the POS sale as usual. 

Redeeming Layaways Originating from a Deposit on Repairs Screen 

To redeem a layaway originally set up by taking a deposit on the Repairs tab, access the original 

repair record. If the customer has the Claim Check, go to the Repairs tab and enter the Repair# in 

the ñJump to repair #ò field.  If not, access the customerôs history on the Customers screen.  The 

description in the Accts section usually has the information you need to determine the 

corresponding repair transaction (as shown next).   
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Double-click the repair record and it displays on the Repairs tab. Click the ñAdd to POS Ticketò 

button.  Then select ñYesò on the ñApply the deposit already made?ò prompt.  The total payment 

amount made on this layaway (listed on the Layaway/Accounts screen) will display in the New 

Payment screen. Enter the rest of the details as appropriate.   

The system will create a POS ticket with the repair ticket transaction and the payment total 

transaction (or add them to an open POS ticket).  On the POS screen, click ñTotalò to display any 

balance due and complete the POS sale as usual. 

Redeeming Manually Entered Layaways 

If the layaway was set up manually (such as when initially implementing TRS), you must add the 

item(s) on layaway to a POS ticket.  For example, enter (or access) the sale record for a sewing 

machine and add it to a POS ticket.  On the POS screen, click ñApply Layaway/Credit/Chargeò 

and select the ñApply layaway payments to the saleò option.  Select the appropriate account from 

the list displayed. 

The Apply Layaway screen displays with the total payment amount.  Enter the rest of the details 

as appropriate. The total payment transaction will be added to the POS ticket.  On the POS 

screen, click ñTotalò to display any balance due and complete the POS sale as usual. 

Alternately, after you enter the items on the POS ticket, you can display the customerôs account 

on the Accounts/Layaways screen and click the ñApply Payments to Saleò button.  Enter the total 

payments received in the Debit Amount field and other details as appropriate.  The layaway 

payments transaction will be added to the POS ticket. 

Store Charge Accounts  

TRS will create and track Store Charge Accounts for your customers, if desired.  Credit limits 

and terms should be set in the Customers tab for each charge customer.  Manually setting up 

store charge accounts will usually only need to be done when you initially implement TRS.  
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Once you are ñliveò on the system, charge accounts and charges to the accounts may easily be 

created from the POS screen.  

Adding New Charge Accounts  

New charge accounts may be either set up from the POS screen after items to be charged have 

been entered on the ticket or they may be set up manually on this tab (Accounts/Layaways).  

Both procedures are described below. 

New Store Charge Accounts from POS 

You can create a charge account for a customer directly from the POS screen.  Once you have 

entered all the items on the POS ticket to be charged to a store account, click the ñApply 

Layaway/Credit/Chargeò button.  

 

The account selection screen displays.   

 

Click the ñCharge all/part to a Store Charge Accountò button.  A list displays with any existing 

accounts and the options to create a new charge account. 




















































































































































































































































































































